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This guide is directed toward people who need to review OpenRoads project data.  The emphasis is 
viewing, not editing. This guide assumes the reviewer knows how to use MicroStation.  The following 
fundamental reviews are discussed. 

1. Working with Multiple Models. 
2. Measure station, offset and elevation 
3. Review profiles data 
4. Review Cross Sections  

a. Dynamic Version 
b. Sheet Version 

 

Working with Multiple Models 
OpenRoads frequently use separate drawing models.   Models are separate drawing containers within a 
drawing file.  Drawings that use OpenRoads Features often have separate 2D and 3D drawings that are 
linked.  This link is part of the “Design Intent” functionality.  Example, sometimes if you modify an 
element in a 2D model, a linked element in the 3D will automatically change.    

There are two categories of drawing model views; MicroStation model views and OpenRoads multi-
model views.  

1. MicroStation Models Views 
a. Can be accessed with or without Geopak SS4 
b. Three types of MicroStation Models – Design, Drawing and Sheet 

i. Design Models are most common at NDDOT -  2D or 3D 
ii. Sheet Models are rarely used at NDDOT 

iii. Drawing Models are used for Open Roads Cross Sections 
c. Referencing can be used to view multiple drawing models at one time. 
d. View Attributes tool is another way to look at a model that is different than the active. 

2. Multi-Model Views include Profiles and Dynamic Cross Sections 
a. Requires Geopak SS4 to be accessed 
b. Require Accessing and OpenRoads Features, usually an alignment, terrain or corridor. 
c. Not intended for Direct Print – Plan Production.  Profiles and Cross Sections are redrawn 

into other MicroStation Model Views for plan production. 

Many of the tools used with OpenRoads need to be initiated from a certain model or a certain view.  
Some tools require accessing multiple view windows.  OpenRoads users should have a good 
understanding of Models and the View Groups Tools.   These MicroStation tools have a limited overview 
in this guide. 
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The view group tools are usually docked at the bottom of the MicroStation application window.  They 
can also be accessed from “Main Menu > Tools > View Groups”. 

 

 

The models tools can be access in the primary tool tray or “Main Menu > File > Models”. 
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Some workflows require file referencing using a certain Model.  

 

 

 

 

 

 

 

 

 

 

 

Some complex workflows require that the default 2D model 
be the active model while accessing a view of a different 
model type such as 3D.  This can be done with the View 
Attributes tools. 
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Measure Station, Offset and Elevation 
Reference civil geometry graphics. 
Civil geometry information is typically stored in a file Named DS_Align.dgn.  If you’re reviewing just the 
existing alignment information, the drawing control.dgn can also be used.  The drawing with the civil 
geometry graphics (alignment) needs to be active or referenced into the drawing that you want to use 
stationing.   

Alignment information is obtained from civil geometry graphics.  OpenRoads alignment graphics contain 
more information than Geopak alignment graphics.  The OpenRoads tool (civil accudraw) is severely 
limited with Geopak alignments or simple MicroStation graphics. If the graphic is not an OpenRoads 
alignment, the graphic will start at station 0+00 and won’t recognize station equations. 

After locating the alignment graphic, confirm that it is 
OpenRoads civil geometry.  This isn’t a required step, 
but it can help you avoid the frustration of 
mismatching stationing.  Get the “element 
information” of the graphics.  OpenRoads civil 
geometry stationing typically has the following 
characteristics.  

1. Complex Element – Tangents, Curves and 
Spirals are linked together to form one 
element. 

2. Assigned Stationing – If you expand the 
Complex Element definition, you can see the 
“Stationing” attributes. 

3. Assigned Feature Definition – Most alignments 
will have a feature definition name starting 
with the work “Alignment”. 

 

 

 

Activate Civil AccuDraw 
After the civil geometry alignment has been displayed and 
identified as discussed previously, activate civil accudraw.  This 
tool is accessible in the tasks (Civil Tools \ General Geometry \ 
Civil Toggles).   The “General Geometry” task is also a common 
task referece to Many NDDOT Design and Survey task groups. 
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The Civil AccuDraw tool bar should open.  This procedure 
will use the first and eighth tool in the tool bar. The first 
tool is used to toggle on and off civil accudraw.  The eigth 
tool is Station-Offset.  Both these should be on (tool button should be depressed). 

 

Place Line 2D 
OpenRoads SS4 doesn’t have a tool like Geopak - plan view labeler.  This guide will use the place line 
tool in conjunction with civil accudraw to query or mark locations with station and offset.  The place line 
tool isn’t the only tool that works with civil accudraw.  The place line too is just a common example. 

Activate a place line tool.  With the civil accudraw setting 
adjusted as previously discussed, your cursor should now display 
setting for station and offset.  

Press the key “O”.  This will prompt you to “Select a Reference 
Element” or Alignment to use with station and offset.  Select the 
applicable alignment. 

The cursor cross hairs should change to one that is 
perpendicular and one that is parallel to the alignment.  The 
station and offset should change as you move the cursor.  Use a 
snap if you want to get the exact location of a MicroStation 
graphic.  The place line command doesn’t need to be completed after the station and offset has been 
queried.   

If a specific point needs to be located, type in values to issue a specific data point.  Use the “Tab” key to 
cycle between the Station and Offset Fields.  Use the “Enter” key to lock a field value.  Use the “End” 
key to unlock a field.  Click in the drawing to issue the point.  If the field is locked when the point is 
issued, the location described by the field will be used instead of the action data point.      

Place Line 3D 
The 3D process for civil accudraw is similar to the 2D process.  
Working with 3D data will enable the “Z” field (elevation) or Profile 
Offset.  
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The civil accudraw tool bar will have 2 additional tools to toggle between working with fixed elevations 
or a “profile offset”.  This guide will focus on using fixed elevations.  The “Z” tool should be toggeled 
instead of the “profile offset “tool.  When working with 
station, offset and elevations, 3 tools should be on 
(depressed); Civil Accudraw - Active, Z and Station–Offset.  

When picking reference alignments in 3D,  be sure to pick the 2D reference alignment.  Reference the 
2D alignment model into the 3d model.   Note civil geomentry alignments may have a 3D component.  
Stationing on the 3D alignment may not work correctly (different than 2D stationing).   

 

Review Profile Data 
OpenRoads Profile Graphics don’t work well for plan production.  They are viewed and edited in a 
special model view.  OpenRoads SS4 profiles are dependent on Geopak for plan production tools.  
OpenRoads and Profiles must be exported to Geopak and redrawn with the Design and Computation 
Manager.  OpenRoads SS4 projects will have 2 versions of profiles.  Both versions are required.  
OpenRoads profiles are required for corridor modeling. Geopak profiles are required for plan 
production. 

Geopak tools can be used to review the Geopak version.  However the OpenRoads version and the 
Geopak versions can represent different profiles if one is edited after the other.  In the early phases of 
project development, only the OpenRoads profile version may be needed and the Geopak profile 
version may not have been created or is out dated.  This part of the guide will review an OpenRoads 
profile instead of a Geopak profile. 

Profiles are associated with some type of horizontal alignment.  OpenRoads Profiles are accessed from 
the OpenRoads horizontal civil geometry which is typically in the DS_Align.dgn.  The profile view cannot 
be access from a referenced view.  The profile view is accessed in the drawing with the civil geometry 
elements. 

Select the horizontal civil geometry 
graphic. Then hover your cursor over the 
graphic.  A popup tool bar should 
display.   Select the  second tool in the 
tool bar “Open Profile Model”. 

Open another drawing view window and click in it.  The view should change to a profile view for that 
civil geomentry element.  
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There may be multiple profiles associated with the 
horizontal civil geomentry.  Only one profile or no 
profile can be active profile for that alignment. Select a 
profile graphic then hover your cursor over this 
graphic.  A popup tool bar should appear.  The second 
tool in the tool bar will either be “Set As Active Profile” 
or “Clear Active Profile”.   The profile providing the 
“Clear Active Profile” is the present Active Profile. 

There are 2 types of profiles; Surface Profile from a 
terrain and Complex Profile from Civil Geometry 
(Designed).  If it is a complex profile from civil geometry 
the rules - varibles will appear as dimensions when you 
click on it. This provide basic information like design 
slope and curve lengths.  

Detail information can be obtained from the profile graphic by accessing 
the profile report.  Select the profile. Hover your cursor over the profile 
until the popup tool bar appears and then select the profile report tool.   

The Civil Report Browser should open with profile details. 
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Even though OpenRoads profiles views aren’t presently intended for sheet creation, you can still draw in 
them.  The civil AccuDraw tools accommodate profile views allowing for precision drawing using station 
and elevation. 

Activate Civil AccuDraw.  This is done the same way as discuss for 
horizontal geometry.  Make sure Civil AccuDraw is toggled on and that 
the “Z” option is selected.   

When using a tool like place line, your cursor should display station and 
elevation information within the profile view. Snap to element to get there station and elevation.  Use 
the tab, return and end keys to toggle between fields, lock fields and unlock fields while specifying 
desired proposed locations. 

 

Reviewing Cross Sections 
There are 2 different types of OpenRoads Cross Sections; Dynamic and Sheets.   

Dynamic cross sections use a special model view to view cross sections from a 3D model.   Dynamic cross 
sections are not intended to be used for drawing or printing.  Dynamic cross section are usually used just 
for viewing.   The sheet cross sections can be drawn on and printed.  These cross sections are a snap 
shot from the model and will not automatically updated with model changes.  If the model is updated 
the sheet cross sections usually need to be recreated. 

Dynamic cross section may simplify offset and elevation measurements.  Using the cross section sheets 
to measure offsets and elevations will require indirect measurements from the sheet gridlines. 

Viewing Cross Section Sheet Model 
When you open a cross section drawing, the default 2D model will probably not contain any cross 
sections.  They are written to a separate model.   The cross section elements displayed are static.  They 
will not update with changes to the 3D model.   The cross section model can be reviewed with the basic 
MicroStation view tools such as pan and zoom.  There is also a “Cross Section Viewer” tool that can 
review sections.   This tool is especially helpful when there are numerous sections within a model. 

Access the “Cross Section Viewer” tool from tasks 
tool under Civil Tools > Corridor Modeling > Cross 
Section Viewer.”    
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The “Cross Section Viewer” 
dialog box should open.  Some 
drawings will have multiple 
cross section models.  It is 
possible to use the stationing 
from a model that your not 
viewing.  Make sure to set the 
cross section model setting to 
the cross section model that 
you are view in order to avoid 
confusion.  Smaller zoom factors provide a closer view.  The Movie Mode tool will sequentally display 
each section for a selected duration of time.  If you select a Cross Section Station in the right panel, 
microstation will center the view on the section and change the zoom factor realative to the section.  
When a station is selected in this pannel you can then use the Up and Down arrows on your keyboard to 
scroll forward or backward through your cross sections.  

Advanced Viewing Cross Section Sheet Model 
The Cross Section Viewer can be used scroll through the cross section within a model and pan over the 
respective location in a plan view.  A pattern line will also display in the plan view at the location of the 
cross section. 

Set the 2D plan view drawing as the active model.  Open a 
second view and change the “View Attributes” to look at the 
desired cross section view but keep the 2D plan view as the 
active model.  Within the “Cross Section Viewer” dialog, set 
the “Plan View” number.  If there is just one view open and it 
is set to the cross section view the “Plan View” field will be 
disabled. 
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Dynamic Cross Sections (Open Cross Section View) 
Dynamic Cross Sections reference a 3D model.  The elements within the 3D model are dynamically cut 
into a separate MicroStation View Window.  Dynamic Cross Section also require an alignment which is 
typically show in 2D.   

Open or create a drawing and model that has both the 
desired 3D models and alignment as a reference or 
active model.  From the Corridor Modeling Task group, 
select the “Open Cross Section View” tool.   Next, you 
will be prompted to select the desired corridor or 
alignment.   If you pick a corridor,  the corridor 
alignment and intervall will be used.  If you pick an 
alignment, you will be prompted for the left offset, right 
offset and the cross section viewing  interval.   

 

 

 

 

 

 

 

 

 

 

 

 

 

When prompted, open and select a separate view other than your model view.  The view display should 
change to cross section view.   

The starting view may be zoomed out so far that it may be difficult to recognized section details. Realize 
that everything in the 3D model is being cut into this dynamic cross section.  If your 3D model displays 
element that are typically drawn in 2D, the 2D elements are usually drawn at elevation 0.   Displaying 
both elements at elevation 0 and elements at actual project elevations will typically create a wided 
(zoomed out) default cross section view.  Use level display controls to turn off the levels that contain 
elements at elevation 0 inorder to simplify view controls.   
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The view controls near the top 
of the window will be 
specifically for cross sections. 

The cross section view 
requires you to use mouse and 
keyboard shortcuts for basic 
view controls like zoom and 
pan.   The typical view controls 
are not docked within the 
window.  Note, the “View 
Control” tool box can manually 
be opend but not docked for the cross section view  (Main Menu > Tools > View > View Control). 

Many of the “View Properties” don’t work or have limitted functionality if the cross section view was set 
up with only an alignment.  Options like “Center on Current Offsets” work better when a corridor is used 
to set up the cross section view. 

The “Display Cut and Fill Graphics” and “Display Cut and Fill Values” only work within the drawing that 
contains the corridor.  These options will not work if you are viewing the coridor by a reference file. 

The following is an overview of basic cross section view controls 
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If you left click and press within the cross section view, within an open space (not on a graphic element), 
the following popup menu should appear. 

 

The “Locate Station via Data point” command will select a dynamic cross section at a location you pick 
from within a MicroStation view window containing a plan view.  Be sure to follow the prompts shown 
in the lower left corner of MicroStation application window. 
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