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Overview 
11/26/13 

 

The guide discusses procedures for calculating final earthwork quantities using GEOPAK.   This 

is abbreviated guidance.  Only some of the more common techniques for calculating earthwork 

are discussed in this manual.  For a more comprehensive discussion of using GEOPAK and 

calculating earthwork see the GEOPAK help files within the application. 

 

This guide does not discuss survey techniques and practices need for calculating earthwork. 

 

This guide discusses two methods of calculating earthwork; 

1. Average End Area Method from Cross Sections 

2. Surface to Surface Volumes from Digital Terrain Models 

 

Some of the procedures needed to calculate earthwork are the same for both methods and some 

are different.  The following outline highlights the procedures are applicable to each method.  

1. Average End Area Method from Cross Sections 

a. Determine Method of Calculating Earthwork....................................page 3 

b. Setting Up or Identifying the Working Directory ..............................page 3 

c. Preparing Files ...................................................................................page 4 

d. GEOPAK User Preferences ...............................................................page 6,7,10 

e. Creating a Digital Terrain Model (DTM) ..........................................page 13,14,17 

f. Reviewing and Displaying a DTM ....................................................page 25,27 

g. Storing a Horizontal Alignment (Chain) ............................................page 31 

h. Drawing Cross Sections .....................................................................page 36 

i. Viewing Cross Sections .....................................................................page 48 

j. Processing Cross Sections for Closure Errors ...................................page 50 

k. Draw Pattern Lines for XS .................................................................page 55 

l. Draw Pavement. Base and Topsoil into Cross Sections ....................page 56,59,62 

m. Earthwork From Cross Sections ........................................................page 68,71 

n. Reviewing Cross Sections..................................................................page 48,74 

o. Creating Cross Section Layout Sheets ...............................................page 76 

 

2. Surface to Surface Volumes from Digital Terrain Models 

a. Determine Method of Calculating Earthwork....................................page 3 

b. Setting Up or Identifying the Working Directory ..............................page 3 

c. Preparing Files ...................................................................................page 4 

d. GEOPAK User Preferences ...............................................................page 6,7,10 

e. Creating a Digital Terrain Model (DTM) ..........................................page 13,14,17 

f. Reviewing and Displaying a DTM ....................................................page 25 

g. Earthwork Quantities by Using Surface to Surface Volume from Digital Terrain 

Models................................................................................................page 30 
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Most of the procedures discussed in this guidance are listed chronologically. When using this 

guidance you need to reference the above outline to know which procedures are applicable to 

your calculations. 

 



 

NDDOT Procedures for Calculating Final Earthwork Quantities 3 
Revised: 11/26/13 

Determine Method of Calculating Earthwork 
03/24/06 

 

If you are calculating earthwork quantities for a roadway, you should use the “Average End Area 

Method from Cross Sections”.  Plan Quantities (as-designed) have been already calculated.  If so 

you will want to compare the as-designed quantities with the as-built quantities. 

 

If you are calculating earthwork quantities for a borrow, waste or stockpile site you probably 

should use the “Surface to Surface Volumes from Digital Terrain Models” method.  This method 

is more applicable to small and less linear sites.   

 

There are some exceptions to the above recommendations.  Occasionally, the “Surface to Surface 

Volumes from Digital Terrain Models” calculation method has been used for complex sections 

of roadways like at an interchange.   However advanced DTM modeling skills are required 

(GEOPAK Site) to use “Surface to Surface Volumes From Digital Terrain Models” when 

materials removed such as pavement removal and materials add such as new pavement intersect 

in space.  Interim DTM’s with these surfaces removed need to be created.  This advanced 

modeling is not covered in this guide.  Surface to Surface Volume comparisons don’t allow for 

haul distance comparison.  If average haul needs to be recalculated, cross sections need to be 

used. 

 

Sometimes the “Average End Area Method from Cross Sections” method is used for borrow, 

waste or stockpile sites because the information was gathered by field book notes (without 

electronic data gathering tools).  The “Average End Area Method from Cross Sections” is also 

used when a site needs to be formally document by cross sections. 

 

Occasionally both methods of calculating earthwork are used for comparison. 

 

 

Setting Up or Identifying the Working Directory 
11/20/08 

 

Electronic files used for final earthwork calculations should be stored on the NDDOT Central 

Office CADD Server (r: drive).  Final earthwork quantity information should typically be stored 

in the “as-built” directory of the project folder.  See the NDDOT CADD Standards Manual 

section 2.1. 

 

You may want to initially store project files in a working directory on the c: or g: drive.  After 

you are satisfied with the results of your earthwork you must move this information to the correct 

project file on the r: drive so it can be stored with the rest of the projects final records.   
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Preparing Files 
11/17/13 

 

Earthwork by Cross Sections for Roadways 

If you are calculating earthwork by cross sections and comparing it to as-designed calculations 

you will probably start out with the following files. 

1. GEOPAK database file (*.gpk) from design  

2. Cross-Section Drawing (xsec_*.dgn) from design - Copy the design cross section 

drawing into your working directory (as-built directory). 

3. A final ground data file from survey 

4. Selected CADD resource file (generic input files) from 

S:\STANDARD\V8i\GEOPAK\Criteria\As-built_Earthwork. 

Note, “DTM.dgn” and “Shape.dgn” are optional files that could be copied but recreating these 

drawings is recommended. 

 

Earthwork by Cross Sections for Borrow, Waste or Stockpile Sites  

If you are calculating earthwork by cross-sections for a borrow, waste or stockpile site (starting 

from scratch), you will probably start out with the following files 

1. Existing ground data from a survey 

2. Final ground data from a survey 

3. Selected CADD resource file (generic input files) from S:\STANDARD\V8i 

\GEOPAK\Criteria\As-built_Earthwork. 

Note, the drawings “DTM.dgn”, “xsec*.dgn”, “Align.dgn” and a new GEOPAK database file 

(*.gpk) will need to be created for these calculations.  If you are calculating earthwork for a 

borrow, waste or stockpile site you probably are not referencing any previously defined 

alignments and it will simpler to create a new “.gpk” file. 

 

 

Earthwork from Surfaces 

If you are calculating earthwork directly from surfaces for a borrow, waste or stockpile site 

(starting from scratch), you will probably start out with the following files 

1. Existing ground data from a survey 

2. Final ground data from a survey 

Note, the drawing “DTM.dgn” and a new GEOPAK database file (*.gpk) will need to be created 

for these calculations. 

 

The survey data is usually in stored in files with a .txt, .csv, .asc or .dat extension.  This data will 

be used to create surfaces and or cross-sections that GEOPAK will use for earthwork 

calculations. 
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The most common surface model that the NDDOT uses is a “triangulated irregular network” of 

points.  This surface is stored in a file with a “.tin” extension.  This surface is sometime referred 

to as a “digital terrain model” (DTM).  You will need these files to calculate earthwork.  The 

only time you will not need at least one *.tin file is when both of the following conditions occur; 

you use the “Average End Area Method from Cross Sections” and final cross section data is 

taken at the exact same stations as the existing ground data was surveyed.  
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GEOPAK User Preferences 
11/12/08 

 

Certain user preferences need to be set up when you use GEOPAK.  The “User Preferences” 

dialog can be accessed from the “Applications>Road>User Preferences” pull down menu.  You 

need to set these directories so that GEOPAK stores information in the correct location.  If you 

do not check these preference settings you could save data over somebody else’s.  These 

preferences should be checked every time you use GEOPAK. 

 

Set the working directory path in this 

command box.  Use the asbuilt or 

directory discussed in the “Working 

Directory” section of this guide. Once 

you have set the working directory you 

may need to set the COGO Preference.  

Select the COGO Preferences button.  

This should open the COGO 

Preferences dialog box. 

 

 

 

 

Most of these setting are left empty.  If the fields for 

“Job (GPK) Directory”, “COGO Input File 

Directory”, and “COGO Output File Directory”, are 

empty, these settings will default to the “Working 

Directory” as previously setup.  Occasionally you 

may want to set the Job (GPK) Directory if your 

“Working Directory” doesn’t contain the GPK file 

that you are working with (example: your “Working 

Directory” is \\Asbuilt and the GPK file is in the 

\\Design directory).   Once this is complete or settings 

have been confirmed (usually as shown) push the OK 

button to close the two dialog boxes. 

 

GEOPAK has a tool named “Project Manager” that helps manage settings for a project.  Project 

Manager overwrites several GEOPAK user preferences. 

 

Some settings such as “Global Working Directory” are only available in Project Manager.  You 

may have to activate “Project Manager” to edit this setting. 

  

file://asbuilt
file://Design
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Project Manager Setup for GEOPAK Road 
11/12/08 

 

1. Project manager can be activated from the main pull 

down menu, “Applications>Road>Project Manager”, or 

the GEOPAK Road tool box. 

 

2. The Project Manager dialog box for project selection or 

setup should open.  Select the directory where you want 

to save the “*.prj” file.  The prj file is a “project” file that 

is used to point to other project manager resources. This 

file is typically stored in your project working directory.  

Use the “Directories:” panel to select the working 

directory.  Note, the path shown as “[..]” selects a parent 

directory of the presently selected directory (moves out 

one directory).  The selected directory will show near the 

top of the dialog box.  In this picture it is shown as 

“C:\Junk\”. 

 

 

 

 

3. After the location for the “*.prj” (project) 

file has been selected.  Create the project 

file by selecting “Projects>New” from the 

Project Manager dialog box for projects.  

A “Create New Project” dialog box will 

open.  Type an applicable “Project 

Name:” (example, Hwy2_MP199).  

Usually there is only one prj file per 

working directory so the naming 

convention isn’t extremely important.  

Select the working directory and a Job 

Number for the GPK file.  If you select a Job Number for a GPK file that doesn’t exist, a 

new GPK file will be created.  The Project Description is optional.  
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4. Select the “OK” button after filling the information for 

the “Create New Project” dialog box.  The Project Name 

should now show up in the Project Manager dialog box 

for projects.  Select the “OK” button to select the newly 

created project.  A “Project Users:” dialog box should 

open. 

 

 

 

 

 

 

 

 

 

5. Project manager can keep track and segregate 

the work of several different users if the 

separate users are setup.  Select “Users>New” 

from the Project Users dialog box. 

 

 

 

 

 

 

 

 

6. Fill out the information for the New User.  The Name 

should be your NDDOT email name (example, 

“jcollado”).  The CADD Standards Promote using 

your email name because this name should be unique 

within the NDDOT.  Example, there could be more 

than one person named “Jon” working on the same 

project.  Users sharing the same name at the same 

time within one project manager may cause 

problems such as crashing and corruption of 

project manager files.  The “Full Name” field should 

just be your full name (example, “Jon Collado”).  The 

OP code: should be “nd”.  This is an Operator Code.  It is used in some files named by 

GEOAPAK. The description is optional.  Select the “OK” button after the user 

information has been set up.  You will be prompted to password protect your files. Select 

No. 
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7. Within the Project User dialog box, select the user. 

The user should be highlighted in the Project Users 

panel.  Select the “OK” button and the “Road 

Project” dialog box will open. 

 

 

 

 

 

 

 

 

 

 

8. This is the “Road Project” dialog box.  It is very robust and this manual will discuss only 

a few of its features.   This dialog box may be used when drawing cross section elements 

and calculating earthwork as discussed latter in this manual.  

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

9. The “Working Alignment Influence Runs” is a setting that is not used in this manual.  

You may not always have one fixed working alignment definition for one alignment. For 

simplicity, toggle this option off.  
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Survey Project Preferences 
11/1713 

 

GEOPAK Survey uses a “*.prj” project file similar to Project Manager.  Using GEOPAK Survey 

and Project Manager for Road at the same time is not recommended. 

 

 

1. GEOPAK Survey can be activated by selecting “Applications>Survey” from the main 

pull down menu.  The “Survey Tool Box” and a separate survey menu bar should open. 

Most of  the same tools can be access from either the tool box or the menu bar.  This 

manual will use the menu bar for the most part. 

 
 

2.  Several preferences need to be 

setup.  From the Survey menu 

bar select 

“Project>Preferences”.  The 

Preferences dialog box should 

open.  

 

3. Many of these preferences can 

be imported by selecting 

“Default>Open”.  Pick the file 

“S:\STANDARD\ V8i\ 

GEOPAK\Survey\NDDOT.sdp”.  Notice the name of the dialog box changes from 

“Preferences” to “Default Preferences”. 

 

4. Several “default” preferences will be load such as; Dataset>Linking Codes, 

Visualization>Settings, and Visualization>Cross Sections.  However you will need to 

edit several Project preferences. 

 

5. Select the “Project” tab in the preferences dialog box.  On the left side of the dialog box 

there is a selection panel. Select “Settings”.  
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6. Rename the project “Name” from 

untitled.prj to something more 

applicable (example, 

Hwy2_MP199.prj).  Usually 

there is only one prj file per 

working directory so the naming 

convention isn’t extremely 

important.  Select the Directory 

and Job Directory. These 

directories should typically be set 

to the project working directory.  

Setting the Global Working Directory is not recommended because it can’t be adjusted 

outside of GEOPAK Survey.  Set the Job Number for the GPK file.  If you select a Job 

Number for a GPK file that doesn’t exist, a new GPK file will be created.  The Project 

Description is optional.  

 

7. On the left side of the “Default Preferences” dialog box, select “User” in the selection 

panel. 

 

10. Fill out the information for 

User.  The Name should be 

your NDDOT email name 

(example, “jcollado”).  The 

CADD Standards Promote 

using your email name 

because this name should be 

unique within the NDDOT.  

Example, there could be more 

than one person named “Jon” 

working on the same project.  

Users sharing the same name at the same time within one project may cause 

problems such as crashing and corruption of project manager files.  The “Full 

Name” field should just be your full name (example, “Jon Collado”).  The OP code: 

should be “nd”.  This is an Operator Code.  It is used in some files named by GEOAPAK. 

The description is optional.  Don’t use the password field. Select the “OK” button after 

the user information has been set up.    

 

11. The following settings (Dataset>Linking Codes, Visualization>Settings, and 

Visualization>Cross Sections) should have been imported from the NDDOT.sdp file.  

They will be reviewed for informational purposes. 
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12. The Linking Codes can be 

set under the “Dataset” tab 

within the “Linking 

Codes” panel extension.  

The Linking Codes are 

also discussed in the 

NDDOT CADD 

Standards, Section 4.6.   

 

 

 

 

13. Under the 

“Visualization>Settings” 

the standard nddot.smb 

should be selected and the 

“Apply Feature Best 

Match” should be activated.  

The “Apply Feature Best 

Match” option allows slight 

variations of a point code 

names (example; BRK1, 

BRK2 and BRK3 will all be 

considered as break lines 

“BRK”). 

 

 

 

14. Under the “Visualization>Cross Section” the standard symbology for cross sections is 

setup for existing ground. 

 

15. The Default Preferences must be resaved after the editing.  If you don’t save them, they 

will be lost.  Default Preferences are not the same as active Preferences.  Default 

Preferences are stored in a *.spd file.   Active Preferences are temporarily stored in a rsc 

file.  Select “Default>Save As” from the Default Preferences dialog box to save the 

project default settings.  Using the same names for the *.prj and the *.spd files is 

recommend for intuitive file navigation.  

 

16. Select the “OK” button after the preferences have been set up.  The “Project Preferences” 

dialog box will close. 
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Creating a Digital Terrain Model (DTM) 

11/17/13 

 

Digital Terrain Models are often used for drawing cross sections and earthwork.  Usually DTM’s 

are needed for both existing and as-built ground surfaces.  DTM’s are often stored in files with a 

“.tin” extension.   

 

Sometimes projects may not require field personnel to create a DTM.  Here are some instances 

when you many not need to create a DTM 

 

1. Someone else has created a DTM for you.  DTM’s of existing ground for roadway 

alignments are often created by Surveys and Photogrametry in the Design Division.  

If you are working on roadway earthwork you may be able to use the DTM that 

Design created.  However, Design seldom creates as-built DTM’s.  So Field 

personnel may be required to make as-built DTM. 

 

2. If field data was taken at regular intervals – transversely at specific stations, a DTM 

may not be required.  Cross Sections can be created directly from data files that 

contain station, northing, easting and elevation information or cross sections can be 

created directly from data files that contain station, offset and elevation information.  

However, the stationing for the existing cross sections must match the stationing for 

the as-built cross sections.  If additional cross sections are needed, additional field 

data will need to be collected.  Choosing to collect data at regular intervals in order to 

directly create cross sections (skip creating a DTM) does not usually save time.  

Using xyz data collected transversely across a roadway instead of at irregular 

intervals in order to create a DTM is discouraged because the cross sections obtained 

from these DTM’s are often misinterpreted.  

 

If you don’t need to make a DTM you can skip the following step.  The following procedures 

discuss how to create a DTM.  Both GEOPAK Road and GEOPAK Survey can be used to create 

a DTM.  There are variations of both of DTM creations methods.  Both of these methods extract 

survey data from a text file. 

 

Two methods are presented here.  However, using GEOPAK Survey to visualize the data before 

creating a DTM is strongly recommended.  Visualizing the data early on in the process may 

point out surveying short comings.   The GEOPAK Road method can use break lines, but it 

requires more work to correct problems.   Sometimes these problems are easier to correct by 

graphical methods and you’ll end up extracting graphics anyway. 
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Creating a DTM using GEOPAK Road 

 

1. Create and or Open the drawing DTM.dgn.  For this simplified DTM use the standard 

seed file “S:\STANDARD\ V8i\seed\NDDOTseed_3D.dgn”. 

  

2. Select “Applications> ROAD>DTM Tools” from the main pull down 

menu.  The following tool box will appear. 

 

3. From the DTM tool box, select the “DTM Menu” tool (it is the icon 

that looks like a data collector).  The menu bar shown below should 

appear. 

 

 

 

 

4. Select “Extract>XYZ” form the DTM menu bar.  The following dialog box will 

appear.

 
 

5. The input File is the file from your total station survey equipment.  It should have a 

point number, Northing, Easting, and Elevation.  The data may also contain Link 

Codes, Point Codes and Comments.   

 

6. The output file is the file that GEOPAK will create.  This file usually has a “dat” 

extension.   In proceeding steps the “dat” file will be used to make a “tin” or DTM 

file.  In review, the survey ASCI “asc” file is used to create a GEOPAK output data 

“dat” file which will then be used to create a DTM “tin” file.  Your file name should 

be something that you can recognize from the name.  It is a good practice to use the 

same name with different extensions for the creation of one surface (example: 

pile4final.asc, pile4final.dat, pile4final.tin).  You can use the File buttons to set these 

and it should be stored in the working directory. 
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7. Once you have set the “Input File” and “Output File” the contents of the input file 

should be similar to the one shown in step 4.  GEOPAK is particular in that the 

Delimiter and the Comment Delimiter can not be the same.  So you may need to edit 

the file you got from your total station so, for example there is only a “comma” that 

separates the Northing, Easting and Elevation and a “*” that separates your 

comments.  Once you have selected your input file and delimiters, select the first line 

of the input file as shown in the “Contents of File” panel.  The data contained on that 

line should appear above the buttons that say “None”.  Next select each button that 

has something above it and set it to the feature that best identifies it.   

 

8. Link and point codes can also be 

setup.  Select the “Feature 

Setting” button.  The “Feature 

Settings Dialog” box should 

open.  From this dialog box, 

select “File>Open”.  The settings 

for this dialog have been saved to 

a file named 

“Limitted_DTM_Features.adf”.  

This file can be copied from 

S:\STANDARD\ V8i\GEOPAK\Survey.  This file should be reviewed to see if all 

your pcodes are included.  If they are not included you will need to add them.  

 

9. In the “Extract XYZ” dialog box, make sure “Apply Best Match Feature Code” 

toggle is on.  This is import because we number features to be identified and 

addressed similar to unnumbered features (example, BRK, BRK1, and BRK2 will be 

treated the same way) 

 

10. From the “Extract XYZ” dialog box, select the “Linking Code” 

button.  Fill out the codes as shown. 

 

11. From the “Extract XYZ” dialog box, choose the “Process” 

button.   

 

12. If you haven’t assigned PCodes, you may receive an alert if you 

are not using the point code.  Say OK to the alert, the PCode is not mandatory.  

GEOPAK will create the “dat” file.  You can use Windows Explorer to confirm its 

creation.  After the “dat” file has been created the “Extract XYZ” dialog box can be 

closed. 
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13. The next step is to build the triangles.  

This is done by choosing 

“Build>Triangles” from the DTM menu 

bar.  The following box will appear. 

 

14. The Data File in this box is the name of 

the file that you just created in the 

previous steps.  The TIN file name should 

again be a file name that you can 

recognize from its name.  The Dissolve Option will help eliminate any unwanted 

triangles.  Your triangles generally do not have very long sides but this depends on 

how close of shots the surveyor took.  My suggestion is to set the Dissolve Option to 

“Side” and input a side length of 200.  Once you have done this you want to choose 

the “Process” button. 

 

15. At this point you should have a “tin” file –have created at DTM.  These steps will 

need to be repeated if you have multiple surfaces (example: existing ground and as-

built ground). 
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Creating a DTM using GEOPAK Survey 

 

This section discusses how to extract survey information from a text file into a drawing and then 

extract the drawing information into a DTM. The advantage with this method is that the break 

lines can be visually reviewed before the DTM is created.  The intermediate step of extracting 

the survey data into a drawing will allow for visually checking the data for crossing break lines 

and Boundaries.  

 

1. Create and or Open the drawing DTM.dgn.  For this DTM creation method the 3D 

seed file “S:\STANDARD\ V8i\seed\NDDOTseed_3D.dgn” will be required.  If you 

are modeling both existing (preconstruction) and as-built (new) conditions, using two 

different drawings (DTM_exst.dgn and DTM_asbuilt.dgn) is recommended.  This 

will simplify the process by helping to prevent existing elements from getting into the 

as-built DTM and prevent as-built materials from getting into the existing DTM. 

 

2. Select “Applications>SURVEY>Survey”.  A “Survey” menu bar and toolbox should 

appear.  Most of the tools from the menu bar and the tool box are the same.   This 

section will discuss GEOPAK Survey in terms of the menu bar. 

 

 

 

 

 

3. From the Survey menu bar select 

“Project>New”.  If you had previously 

created a Survey Project for a NDDOT 

project, you would select open.  You 

can add multiple cross section data 

sets to your previously stored project 

(example: cross sections for different 

borrow pits).  The box to the right 

should appear.  Fill in the Project 

Name, with a name that refers to the 

area you are working with.  Set the 

Working directory to the same directory that you created earlier, use the select button.  

If you set up the Survey Project Preferences most of this information will already be 

populated. 
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4. You could use the gpk file –job number that is used for alignments but you must be 

certain that point names are not reused.  Often it is easier and safer to create a new 

gpk file just for the dtm extraction.  The Job Number 999 often reference to a 

temporary DTM file.   The project description area is optional.  Then click OK.  The 

“Project New” dialog box should close. 

 

5. Confirm that the “Project Preferences” were setup correctly. See the section title 

“Survey Project Preferences”. 

 

6. From the Survey menu bar select 

“Dataset>New”.  The box to the 

right should appear.  Give the 

data set a name (example: 

Data1).  The Description is 

optional.  Set the “Data Source” 

to “ASCII File(s)” and process to 

“XYZ to Coordinates”.  Set the 

“Output Directory” to your 

Working Directory (As-built 

folder).  Then select the “Dataset 

Add Source File to List” button.  

Then pick the ASCII file that 

contains your survey coordinate 

data.  The panel on the bottom of the “Dataset New” dialog box should show the file 

you just selected.  Next select the “OK” Button. 

 

7. Another dialog box (XYZ to Coordinates) should appear.  The Contents of your 

ASCII file should appear in the middle panel.  Set the appropriate “Delimiter” usually 

“Space” or “,”. Then select the first line of data.  It should become highlighted. 
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8. What you should see happen is that the text of the line you chose appears above the 

button that says none.  Your next step is to click on each of the “none” buttons and 

choose the appropriate description for the text that is above the button.  It should look 

like the box above.  You will need to keep hitting the next bar until you have a 

description under each field of text.   

 

9.  Activate the options “Import After Process” and “Store Elements into GPK”.  Then 

select the “Process” button.  The survey data will be drawn into your 3D drawing. 

 

10. After the data is drawn by GEOPAK Survey it should be examined.  Make sure there 

are no crossing break lines.  Also check the side or front views for drawing – survey 

elements that don’t appear to be on the ground surface (example, check for elements 

that have a negative or zero elevation - all element should appear as if they are on a 

surface with realistic elevations).  The “XYZ to Coordinates” dialog can be closed 

after the drawing has been inspected and corrected.  Problems with surveys and 

surveying techniques are not discussed in this manual. 

 

11. Select “DTM>DTM Tools” from the survey 

menu bar.  From the DTM Tools select Extract 

Graphics. 

 

 

 

 

 

12. The dialog box to the right should 

appear.  This dialog box – tool is used 

to create a “dat” file from the drawing 

graphics.  Provide a file name for the 

dat file.  This data file is usually created 

in two parts.  One part extracts the 

break lines and the other part extracts 

the points.  In the first part of the 

extraction the “File Open” option must 

be set to “Create” and during the second 

part of the extraction the “File Open” 

option must be set to “Append”. 

 

13. The “File Type” can be “Binary” or 

“Ascii”.  “Binary” is smaller and faster 

but it can not be reviewed directly.  An 

“Ascii” file can be reviewed with any 

text editor.  The “File open” option 

needs to be set to “Create” to extract the 

first group of features.  In these 

directions the first group of features will be “Spots”. 
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14. Set the “Search Criteria” for spots.  This criteria should exclude symbology for break 

lines.   The “Match”, “Display”, and “Reset” buttons can be used to help select the 

search criteria. 

 

15. After the search criteria is selected, select the “Extract” option.  If a view is used such 

as “View 1” be sure to adjust the view so you can see the spots that you need to 

extract.  If you are zoomed in and only see some of the points, then only those points 

will be extracted. 

 

16. Select the “Apply” button and the Spots – Points will be imported into the dat file. 

 

17. Switch the “File open” option to “Append” and set the “Feature” option to “Breaks” 

(break lines).  Reset the Search Criteria and select symbology that matches the break 

lines. 

 

18. After the search criteria is selected, select the “Apply” button and the break lines will 

be imported into the dat file.   

 

19. “Boundaries”, “Voids” and other features can also be imported in to the dat file using 

this tool.  Close the “Extract Graphics” dialog box after the dat file has been created. 

 

20. Select “DTM>Build DTM>From Dat File” 

from the Survey menu bar. The “Build 

Triangles” dialog box should open. 

 

21. Select the dat file created previously and 

provide a name for tin file that is about to be 

created.  It is a good habit to use similar 

names for the raw survey asci file, the dat 

file and the tin file. 

 

22. Set the “Dissolve Option” to “Side” and set the “Side Length” to the maximum length 

of the side of a desired exterior tin triangle.  This setting may have to be set by trial 

and error.  If the value is too big, deceptive exterior triangles will be created.  If the 

value is to small, the tin surface coverage may be gapped. See the section of this  

“Reviewing and Displaying a DTM”  

 

23. Select the “Process” button to create the tin.  See the next section of this manual 

“Reviewing and Displaying a DTM”. 
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DTM Creation with “Data Acquisition”   
11/25/13 

 

“Data Acquisition” is the new Bentley survey tool.  Eventually this tool is intended to replace 

Geopak Survey.  Presently Data Acquisition has been implemented at the NDDOT for testing 

purposes.   Users are encouraged to try this tool.  Please report bugs or concerns to the NDDOT 

CADD Support Specialist.  This section was written for GEOPAK SS2.  

 

The following workflow will use a survey text file to make a Geopak tin (dtm).  This workflow 

uses a survey text file that is comma separated; point number, northing, easting, elevation, link 

and point code.  Note, Data Acquisition can use multiple text files to create a single tin (dtm). 

 

 

1. Review survey text files.  Confirm file format as noted above.  Rename file extension to 

txt if other extensions were used. 

 

2. Create a new dtm drawing using the “Data Acquisition” seed file located at;  

S:\STANDARD\V8i\GEOPAK\Survey\Data_Acquisition\Seed_Survey_DA.dgn.  

Note, the NDDOT macros used to create drawings doesn’t use this seed.  The drawing 

needs to be created with this seed file because it contains additional settings and 

preferences. 

 

3. Make sure Geopak is activated.  Geopak just needs to be 

passively running.  You don’t need to activate Geopak 

Survey.  Your Application pull down menu should look 

like this.  
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4.   Active “Data Acquisition” from the “Tasks”. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5.   Two windows will open; Data Acquisition, and Data Acquisition Details. 
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6. Within the Data Acquisition window, right mouse 

button click on “Field Books” and select “New”.   A 

new empty field book (Field Book 1) will be created. 

 

7. Right mouse button click on “Field Book 1” and select 

“Load > File”. 

 

 

 

 

 

 

 

 

8. The “Select File” dialog box should open.  Change the filter to “Comma delimited 

PtNumNEZCodeCode(*.txt).  Then select your survey text file.  Then click open. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

9. The field book will be displayed as MicroStation graphics if the codes are correctly 

identified.  Use a MicroStation “Fit View” tool to find your graphics.  Review these 

graphic. Correct and re-import field books if necessary. 

 

10. Steps 6 through 9 can be repeated for additional survey data files. 
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11. Within the Data Acquisition window.  Click on the plus 

in front of “Surfaces” to expand this branch.  Click on 

the box in front of “All field Books” to display surface 

triangulation. 

 

  

12. Select “Surfaces > All Field Books” from the Data 

Acquisition window.  Options within the “Data 

Acquisition Details” window will change.  Review the 

“Element List > Survey Surface”.  Modify the options 

for “Dissolve Type” and “Side Length” if needed 

(remove external bogus triangles). 

 

 

 

 

 

 

 

 

 

 

 

13. Within the Data Acquisition window, right mouse button click on “All Field Books” and 

select “Export to… > GEOPAK Tin.  The Save As dialog box will open.  Name the file 

and save it to your desired location. 
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Reviewing and Displaying a DTM 
12/26/08 

 

Once you have created existing ground and as-built ground DTM’s, you should compare the 

models by having GEOPAK draw them.  A drawing of the DTM’s will also be required if you 

need to store an alignment through the center of the model.  

 

There are several parts of a DTM that can be displayed. The steps listed here will display the 

TIN Hull (boundary), Triangles and Contours. This drawing can be used to check the coverage.  

The models should overlap and adequately tie to one another.  The points should be dense 

enough to represent the surface.  The Contours from the existing ground and the as-built ground 

should merge near the tie points. 

 

1. This process assumes that the DTM menu bar is loaded and you are in the DTM 

drawing.  If this is not so, see steps 1-3 from “Creating a Digital Terrain Model Using 

GEOPAK Road”. 

 

2. Select “LOAD>DTM 

Features” from the DTM 

menu bar.  The box to the 

right will appear.  Set the 

“Load File” button to 

“TIN”, and then go 

search for the tin files for 

your project.  GEOPAK 

can only draw features 

for one tin – surface at a 

time so these steps will 

have to be repeated for 

each surface.  Set the 

“Load:” option to 

“Extent”.   Turn off the 

“Display Only” option.  

If the “Display Only” 

option is turned on the elements displayed will only be temporary.  They will not be 

saved with the drawing.   Next under the Feature items make sure the Display is on 

for only the Triangles, Tin Hull and Contours.  To do this, you can double click on 

the line that says Triangles.  Do the same for the TIN Hull and Contour lines.  The 

light bulb icons to the right can also be used turn on and off the display of a feature.   
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3. Unique symbology for the different elements, especially for the levels, can simplify 

your review of the “tin”.  Levels can be turned off when they aren’t being reviewed. 

 

 Existing Ground (Preconstruction) As-built 

Feature Level Color Weight Style Level Color Weight Style 

Triangles TIN 1 Triangles 

Lines 

1 0 0 TIN 2 Triangles 

Lines 

2 0 0 

TIN Hull Tin Hull Line 1 1 2 0 Tin Hull Line 2 2 2 0 

Major Lines 

(Contours) 

Contour 1 Index 

Line 

2 2 0 Contour 2 Index 

Line 

4 2 0 

Minor Lines 

(Contours) 

Contour 1 Intmdt 

Line 

3 1 0 Contour 2 Intmdt 

Line 

5 1 0 

Major Label 

(Contours) 

Contour 1 Index 

Line 

2 0 0 Contour 2 Index 

Line 

4 0 0 

 

4. The settings for “Contours” 

such as intervals and labels 

may need to be adjusted for 

your specific project.  The 

elevation “Range” for the 

contours needs to be set or 

“Read”. 

 

5. Once the symbology is set 

choose the “Load” button.  

You should see triangles, 

boundary lines (Tin Hull) 

and contours on your 

MicroStation screen.  If you 

don’t see your DTM use the 

“Fit View” tool in 

MicroStation. 

 

6. Repeat the proceeding steps for the other DTM if needed.  Separate drawings are 

recommended for each DTM.  Presently there isn’t unique symbology for all features 

used in a survey such as break lines and spot shoots. 

 

7. Once both DTM’s are drawn you will probably need to used “Level Display” to turn 

on and off levels to clearly compare tin models. 
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Review DTM by Analysis of Profiles   
11/13/08 

 

This tool can be used to cut profiles- cross sections from one or more DTM’s.  This tool can cut 

several profiles very quickly without storing a formal alignment.  Sometimes it is easier to study 

a profile rather than an entire surface. 

 

1. This process assumes that the DTM menu bar is loaded and you are in the DTM 

drawing.  If this is not so, see steps 1-3 from “Creating a Digital Terrain Model Using 

GEOPAK Road”. 

 

2. Select “Analysis>Profile” from 

the DTM menu bar.  The box 

to the right will appear.  There 

are three icon at the top of the 

dialog box that show different 

parts of the Profile tool;  

 

a. Object selection, 

b. Create Profile 

c. Profile Preferences 

 

3. Pick the Object Selection icon, 

select the “TIN file” for the 

profile.  Just to the right of the 

“TIN File” filed is a symbology button to set the symbology for the profile (example: 

Level =”Profile #1 Line Exst”, color=ByLevel, style=ByLevel, Weight=ByLevel).  

 

4. After the TIN File has been 

selected and the symbology set, 

add the profile to the selection 

by using the “Add List Item” 

button on the right side of the 

dialog box.  Note multiple 

profiles can be cut at one time 

by adding multiple surfaces to 

the selection as in step 3 above.  
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5. Select the “Profile Preference” 

icon.  Set the scale for the 

profile and grid preferences.   

 

 

 

 

 

 

 

 

 

 

 

 

6. Select the “Create Profile” 

icon.  There are two 

methods to cut a profile.  

The “Select Element” to 

identify a previously drawn 

element such as a line or 

line string to cut the profile 

from, or use the “Place 

Element” button to 

temporarily draw a line or 

line string to cut the profile 

from.  

 

7. After the horizontal 

alignment for the profile has 

been selected, the 

“Extracted Profile View” should have been created.  Select the “Place Profile” button 

place the profile in the drawing. The profile will be attached to the cursor and it can 

be placed anywhere in the drawing with a right mouse click. 
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Earthwork Quantities by Using Surface to Surface Volumes 
from Digital Terrain Models 
03/24/06 

 

1. This process assumes that you have existing and as-built DTM’s and that the DTM 

menu bar is loaded.  If it is not, see steps 1-3 from “Creating a Digital Terrain 

Model”. 

 

2. Choose the “Analysis>Volumes” from the DTM 

Menu bar.  The following box will appear. 

 

3. The Prismoidal method should be selected.  The 

Calculation option button should be set to “TIN to 

TIN”.  The “From TIN” should be your existing tin 

file name and the “To TIN” should be your final tin 

file name.   

 

4. Make sure that your “Volume Calculations” dialog 

box is expanded to show all the options.  There is an 

arrow-triangle in the lower right area of the dialog 

box to see the expanded options. 

 

5. Draw a polygon around the area you want to compare 

volumes.  The polygon should be contained within 

both of your DTM’s.  It is important to draw and save 

your boundary polygon incase you need to reproduce 

GEOPAK’s Exact Calculation. 

 

6. In the expanded area of the “Volume Calculations” 

dialog box select the option to “Output to ASCII 

File”.  The ASCII File name should have the same 

path of your project file and you should give it a file 

name that you can recognize from the name.   Select 

the Option “Use Boundary” and select the boundary 

you drew in step 5. 

 

7. Select the “Process” button.  You should see Volume 

Calculations for, Cut Volume, File Volume, Balance, 

and Area.  Remember the volumes may or may not 

include aggregate and pavement.  This is dependent 

on when the survey was done.  The volume data is 

stored in the “Output To ASCII File”.   This file can 

be reviewed with the GEOPAK “Text Editor” or with 

the NOTEPAD application. 
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Storing a Horizontal Alignment (Chain) 
11/20/08 

 

If you are calculating earthwork from cross sections and a horizontal alignment has not 

previously been stored, you will need to store an alignment.  This situation typically occurs when 

you are making cross sections for a borrow, waste or stockpile site.  

 

If you are calculating earthwork for a roadway and comparing as-designed quantities with as-

built quantities a horizontal alignment should already be stored in an existing GPK file.  

 

If you are calculating earthwork directly from surfaces you do not need an alignment. 

 

This section assumes that only a very simple alignment is needed for a borrow, waste, or 

stockpile site.  This simple alignment will consist of only a line with a start and end point.  This 

alignment must extend beyond the affected site (longer than the earthwork area).  This alignment 

should run close to the center of the site.   

 

Some sites require more complex alignments.  Complex alignments are not discussed in this 

manual.  Complex alignments can cause areas of concern such as intersecting cross sections and 

centroid adjustments.   

 

This section discusses how to store an alignment in GEOPAK using the “Store Graphics” tools.  

 

1. Create and open the Align_*.dgn. Make sure you use the standard seed files. 

 

2. Reference in the DTM_*.dgn.  This reference file should have the TIN hulls (survey 

surface boundary drawn in it. 

 

3. Draw a straight line through the site.  The line should be longer than the earthwork 

site - start and end beyond the areas of earthwork.  This line will become the 

GEOPAK alignment.  Make sure to draw the line with the first point representing the 

beginning of the stationing and the second point representing the end of the 

stationing. 

 

4. Open the “Store Graphic” dialog box by selecting 

“Applications>ROAD>Geometry>Store Graphics”.  

You might have to change the element option from 

“Point” to “Chain” within the Store Graphics dialog 

box. 
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5. Fill out the dialog box.  The dialog box to the right 

shows some typical values.  The Job Number is the 

number of the main GEOPAK database.  Don’t 

worry if it doesn’t exist yet.  GEOPAK will prompt 

you for it’s creation in a following step. The 

“Operator Code” should be “ND” this will help 

standardize files created by GEOPAK.  Chain 

names should descriptive like “Borrow1”, “Waste1” 

or “Pile1”.  Point numbers used by the District for 

As-builts should be between 14000-14999.  These 

point numbers have been standardized incase design 

elements need to be merged into the as-built GPK.  

The beginning point should be a point that has not been stored in GEOPAK.  If you 

have other information in this GPK file you need to see what points are available.  If 

you would happen to use a point number that is already used one of two things could 

happen.  If your COGO redefine key is active it will erase the point that is already 

stored or if the redefine key is not active it will not store the new point. 

 

6. Change the button on the bottom of the dialog box from “Complex Chain” to “Single 

Element”.  Note that the “Store” button is disabled at this time. Select “ID Element” 

Button. Then select and accept the element you drew in step 3 (double click on it). 

 

7. After you have accepted the element – line, the 

“Store” button should become enabled.  Select the 

store button to save the alignment into the main GPK 

data base. 

 

 

 

 

 

 

 

8. An ALERT box may appear if the GPK file – “Job Number” doesn’t exist. Click the 

“Yes” button if you wish to create the database.   

 

9. You will also be prompted for an “Input File Name”.  Use the default name provided 

(j001oND.inp).  This file will contain the GEOPAK COGO commands used to create 

the alignment.  This file is only needed if you want to recreate your alignment in 

GEOPAK.  This file will probably not be used again unless something goes wrong 

with your GPK or drawing file (job001.gpk or Align_*.dgn). 
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10. At this point the alignment should be stored in GEOPAK. The following steps are not 

required to store an alignment.  However it is good to review your work and confirm 

that the alignment is in GEOPAK.  Open COGO by selecting “Applications> 

ROAD>Geometry>Coordinate Geometry” from the main pull down menu. 

 

11. A “Coordinate Geometry” box should open.   

Confirm or fill in the “Job Number” and 

“Operator Code” fields.  The “Project Name” 

and “Subject” fields are optional fields used for 

GEOPAK Reports.  Then select the “OK” 

button. 

 

 

 

 

12. The main “Coordinate 

Geometry” box should open.  

From this dialog box, select 

“Tools>Navigator” for the 

pull down menu. 

 

 

 

 

 

 

 

 

 

 

 

13. The “Navigator” dialog box should open.  This tool lets 

you review the elements that are in your gpk file.  Change 

the “Element” type to “Chain”.  The alignment name 

stored previously should appear in the bottom panel of 

the dialog box. 
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14. Select the alignment name.  Then select the 

“Print/Describe Element” icon. 

 

 

 

 

 

 

 

 

 

 

 

15. The main “Coordinate Geometry” box should display coordinate geometry 

information about the alignment. 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

16. After you have reviewed this information, close the “Coordinate Geometry” dialog 

box.  An “Alert” dialog box will open, asking you if you want to save the session.  If 

you are just reviewing the GPK you can exit without saving the session. 

 

17. If something is wrong with the alignment stored in GEOPAK, you will have to repeat 

previous steps.  If you are going to correct elements previously stored in GEOPAK, 

make sure your redefine button is on in COGO.  Redefinition of Elements can also be 

turned on from the “Coordinate Geometry” dialog box by selecting 

“User>Preferences>Redefinition of Elements”.  
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18. If you want to delete elements out of the GEOPAK 

database, you can use the COGO “Navigator” and the 

“Delete Element” button (similar to step 14). 
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Drawing Cross Sections 
10/17/06 

 

There are several different methods to draw cross sections.  These methods are dependent on 

how the field data was collected.  The following methods will be discussed in this guide.  

 

1. Cross Sections by Station Offset Elevation File (*.soe) 

2. Cross Sections by XYZ and Station File (*.xyz or *.cor).  The points surveyed in this 

file are usually collected at “regular” intervals.  Groups of points are collected 

transversally across the road.  This file should not be confused with XYZ files used to 

create a representative DTM in which points are collected at irregular intervals. 

3. Cross Sections by Raw Field Data (Station, Offset, Height of Instrument and Raw 

Rod Readings).  This method is used when electronic data collection tools are not 

available.  Data was collected by a field book.  This method is sometimes used with 

“90-1” surveys.  Creating cross sections by this method can be cumbersome because 

someone has to key-in all the field data into a text file. 

4. Cross Sections from Surfaces (DTM). 

 

 

Cross Sections by Station Offset Elevation File 

 

Electronic data collection tools are usually used with this method.  Survey field data is stored in a 

simple text file with a format similar to the following: 

 

XS station (-)offset elevation (-)offset elevation offset elevation offset elevation 

XS station (-)offset elevation (-)offset elevation offset elevation offset elevation 

 

One line can’t contain more than 6 offsets and elevations.  If more data for one section is needed, 

create another line with the same station.   

 

This section discusses how to draw cross sections from station offset elevation field data using 

GEOPAK Survey. 

 

1. Open your cross section drawing.  See the “Working Files” section of this guide.  

This drawing is probably a new – empty drawing that you had to create. 

 

2. Select “Applications>SURVEY>Survey”.  A “Survey” menu bar and toolbox should 

appear.  Most of the tools from the menu bar and the tool box are the 

same.   This section will discuss GEOPAK Survey in terms of the 

menu bar, so you could close the Survey tool box.   
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3. From the Survey menu bar select 

“Project>New”.  If you had previously 

created a Survey Project for a NDDOT 

project, you would select open.  You can 

add multiple cross section data sets to 

your previously stored project (example: 

cross sections for different borrow pits).  

The box to the right should appear.  Fill 

in the Project Name, with a name that 

refers to the area you are working with.  

Set the Working directory to the same 

directory that you created earlier, use the select button.  The Job Number is the same 

Job number used when we initially went into COGO, which is 001, use the select 

button.  You may want to fill out the project description area but it is optional.  Then 

click OK.  The “Project New” dialog box should close. 

 

4. From the Survey menu bar select 

“Dataset>New”.  The box to the 

right should appear.  Give the data 

set a name (example: Data1).  The 

Description is optional.  Set the 

“Data Source” to “ASCII File(s)” 

and process to “SOE to Cross-

Sections”.  Set the “Output 

Directory” to your Working 

Directory (As-built folder).  Then 

select the “Dataset Add Source File 

to List” button.  Then pick the 

ASCII file that contains your station 

offset elevation survey data.  The 

panel on the  bottom of the “Dataset 

New” dialog box should show the file you just selected.  Next select the “OK” 

Button. 
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5. Another dialog box (SOE to Cross-Section) should appear.  The contents of your asci 

file should appear in the middle pannel.  Set the appropriate “Delimiter” usually 

“Space” or “,”. Then select the first line of data.  It should become highlighted. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

6. What you should see happen is that the text of the line you chose appears above the 

button that says none.  Your next step is to click on each of the “none” buttons and 

choose the appropriate description for the text that is above the button.  It should look 

like the box above.  You will need to keep hitting the next bar until you have a 

description under each set of text.   

 

7. Select the chain for the cross sections.  This alignment must have been previously 

stored into GEOPAK. 

 

8. Select the “Plot Parameter” button in the 

upper left corner of the “SOE to Cross-

Section” dialog box.  Another dialog box (Plot 

Parameters) should appear.  The typical 

parameters are as show to the right.  Don’t 

forget to set the “Cross Section Element 

Symbology:” button.   The “Cross Section 

Element Symbology” should be according to 

the NDDOT CADD Standards.   
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9. After the “SOE to Cross-Cross Section” dialog box has been filled out, select the 

“Process” button. 

 

10. An “Alert” dialog boxes may appear.  This to confirm that you will be drawing Cross-

Sections in the drawing is presently open.  This should be your Cross-Section 

drawing. Select OK. 

 

11. A “Decimal Value” dialog box may also appear 

if data with no decimals were encountered.  

Read the dialog box and enter an appropriate 

value (typically “0”).  Then select OK.   

 

 

 

 

 

 

12. Finally, GEOPAK should draw the cross-

sections.  See the section “Viewing Cross Sections” in this guide if you need help 

reviewing cross sections. 
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Cross Sections by XYZ  and Station File 

 

Electronic data collection tools are usually used with this method.  Survey field data is stored in a 

simple text file with a format similar to the following: 

 

N 1144153.45462497 E 2140039.09114346 ELEV 1153.30000000  STA 0+00.00 

N 1144165.44575907 E 2140039.55234093 ELEV 1153.40000000  STA 0+00.00 

 

Several different formats are acceptable.  The data (northing, easting, elevation and station) must 

exist in one file and it must be delimited.  If there are text strings that are not directly used such 

as the abbreviation “STA” (not the value itself), set this string to “None”. 

 

The process of Cross Sections by a XYZ and Station file is similar to Cross Sections by SOE 

method discussed previously.  Sets 4 and 6 are a little different. 

 

In step 4, the process should be set to “XYZ 

to Cross-Section” instead of “SOE to Cross-

Sections”. 

 

 

 

 

 

 

 

 

 

 

 

 

In step 6, you 

will have to 

setup the fields 

for “Northing, 

Easting, 

Elevation, and 

Station” instead 

of “Station, 

Offset, and 

Elevation”. 
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Cross Sections by Raw Field Data 

 

This process is similar to the previous process “Cross Sections by XYZ and Station File”. 

However, addition steps are needed to process the raw data.  This section will discuss how to use 

COGO to convert raw field book information into a “XYZ and Station File”.  Then the steps in 

the “Cross Sections by XYZ and Station File” section can be used to draw cross sections. 

 

Electronic data collection tools are usually not used with this method. This information is 

collected with a field book and the data will have to be keyed in an ASCII text file with the 

following format: 

 

GROUND chain-name ### OUT xs.xyz 

HI elevation 

GL station rod-reading distance rod-reading distance rod-reading distance 

GL station rod-reading distance rod-reading distance rod-reading distance 

END GROUND 

END 

 

Example: 

 

GRO BASE01 14100 OUT XSEC1.COR 

HI 1163.10 

GL 00+00.00 RT 009.8 133 009.7 121 009.5 101 008.7 96 012.1 88  

GL 00+00.00 RT 013.4 86 011.5 83 007.9 76 005.8 61 004.3 41  

GL 00+00.00 RT 003.7 33 003.4 14 003.8 0 

GL 02+00.00 RT 009.9 133 009.9 123 010.0 103 010.1 84 012.3 77  

GL 02+00.00 RT 012.7 72 012.3 65 011.0 61 008.8 54 007.0 43  

GL 02+00.00 RT 005.4 33 004.8 25 004.2 13 003.9 0 

GL 04+00.00 RT 009.9 133 010.1 116 010.1 103 010.4 77 012.8 72  

GL 04+00.00 RT 013.0 68 012.5 62 009.9 55 006.0 42 004.9 33 

GL 04+00.00 RT 004.7 23 003.8 9 003.6 0 

GL 06+00.00 RT 009.7 133 010.3 103 010.7 84 013.2 78 013.4 73  

GL 06+00.00 RT 012.3 68 010.6 61 007.1 52 005.9 45 005.2 33 

GL 06+00.00 RT 004.8 23 003.3 15 003.6 8 003.7 0 

HI 1163.79 

GL 08+00.00 RT 007.8 133 007.2 121 007.6 105 010.0 95 011.1 87  

GL 08+00.00 RT 011.9 83 014.2 77 014.2 73 013.1 66 011.6 62  

GL 08+00.00 RT 010.9 59 007.7 49 006.0 40 005.8 33 005.3 23  

GL 08+00.00 RT 004.8 13 004.3 6 004.3 0 

GL 10+00.00 RT 006.5 133 006.4 107 006.9 90 010.2 79 013.2 70  

GL 10+00.00 RT 014.1 64 013.2 59 011.8 54 010.3 50 007.8 41  

GL 10+00.00 RT 005.8 33 004.6 18 004.0 12 004.4 6 004.5 0                

END GRO 

END 
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In the example file: 

 

“GROUND”  or “GRO” Is the command to begin a ground based calculation 

 

“BASE01" Is the chain name (alignment) that resides in the GPK file in the 

working directory 

 

“14100"  Is the beginning point number for the points that COGO will 

produce from this run.  It is important to start these numbers with a 

value greater than the numbers used to define the alignment 

(BASE01) otherwise they could be overwritten! 

 

“OUT” Tells the COGO run to send data to an output file 

 

“XSEC1.COR” Is the name of the output file produced.  You can change the 

“XSEC1" part to anything you want 

 

“HI 1163.10" Describes the height of instrument used in the field book cross 

sections 

 

“GL” Is the command for COGO’s Ground Line calculations 

 

“END GRO”  Ends the ground calculation 

 

The stationing is typed following the “GL” command and then the rod reading and distance from 

centerline are added.  Subsequent shots are described with rod reading and offset until the station 

data is completed.  The program does not require + or - signs before entries, as long as the 

centerline shot is entered with a “0".  If data is included for just one side, the entry should be 

preceded by a “RT” or “LT” suffix. 

 

Note: Be sure not to have more than 52 characters per line.  Do not split the rod reading and the 

offset data between lines of data. 

 

The data contained in the field book should be entered into an ASCII text file.  The file should be 

named ***001.IND, where 001 relates to the GPK file in your working directory (example:  

JOB001.GPK) 

  

Once the data has been created, a MicroStation session is initiated in a directory containing the 

project’s GPK file.  A COGO session is activated and the above “***.IND” file is “Loaded” into 

COGO and “Read”.  When the file is “read” GEOPAK creates an ****.COR points file.  You 

should be able to open Windows Explorer and see the new file in your working directory.   

 

At this point we have created X, Y, Z and station coordinates from our input data. To create 

cross sections from this data see the section “Cross Sections by XYZ  and Station File”. 
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Cross Sections from Surfaces (DTM) 

 

This process requires existing and as-built surfaces.  This process is often used to compare as-

designed quantities to as-built quantities.  If so, a designer has probably already created existing 

and proposed cross sections and you will draw as-built ground elements over the top of the 

existing ground. 

 

If this process is used for a borrow, waste or stockpile site you can have GEOPAK draw both 

surfaces at the same time. 

 

Drawing As-built Cross-Sections for As-built to As-designed Comparison 

 

1. Find the working cross section drawing and the GPK file used by the designer for 

proposed cross-sections.  There may be several xsec_*.dgn and GPK files.  You may 

need to review “AAREADME” files in the design directory and or call the designer to 

find the required files. 

 

2. Determine the location of the As-built surface model - *.tin file.  This is a file that 

field personnel typically have to create and is stored in the As-built folder.  If you 

need to create this file, see the section “Creating a DTM”. 

 

3. Copy the working cross sections from Design into the As-built folder.  Then open the 

copied drawing in MicroStation.  Delete everything except existing (preconstruction) 

ground, void ground lines and the green cross section reference cells.  You could 

redraw both existing (preconstruction) ground and as-built ground from the tin files.  

However the same green cross section reference cells should be used.  Most likely 

you will want to compare the as-designed cross sections with the as-built cross 

sections by referencing the as-designed cross sections into the as-builts.  If you use 

the same green cross section reference cells the reference files should be coincidental.   

 

4. If you haven’t copied the GPK file into your working directory (As-built folder), 

make sure to set your “COGO Preferences: Job (GPK) Directory” to the design 

folder.  See the “GEOPAK User Preferences” section of this guide. 
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5. Select “Application>ROAD>Cross 

Sections>Draw Cross Sections 

from Surfaces” from the main pull 

down menu.  The “Draw Cross 

Sections” dialog box should open. 

 

6. Select the appropriate Job Number 

and Chain for the Cross Sections.  

Use the cross section baseline 

chain. The Cross Section baseline-

chain may be different than the 

roadway alignment-chain.  Review 

the green cross section cell to 

determine the baseline chain.  See 

the picture below. 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

7. There should be two tabs in this dialog box; “XS Cells” and “Surfaces”.  You should 

be on the “XS Cells” tab.  Near the middle of the “Draw Cross Sections” dialog box 

there is a “Pattern” panel.   Pattern lines indicate where cross sections should be 

obtained.  Set the pattern toggle to “In Existing Only”.  This setting will obtain cross 

sections at only the locations that the designer used. 
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8. Next set the tab to “Surfaces”.  

Near the bottom of the dialog 

box there should be a panel for 

surface “Details”.  Select the 

as-built TIN File.  Set the 

“Method” to “Triangles”.  Set 

the “Type” to “Line Strings”.  

The Display Settings for the 

As-built ground should be 

according to the CADD 

Standards for Ground Lines: 

Level = “Grnd Line” 

Color = 1 

Style = 0 

Weight = 2 

Void lines should be on the 

same level as as-built ground 

but the color should be white 

“0”.  After setting these details, 

select the “Add Surface” button.  This button is on the right sided of the dialog box.  

The surface information should appear in the middle panel. 

 

9. Select the “Draw” button in the upper right hand corner of the “Draw Cross Sections” 

dialog box.  GEOPAK should draw the as-built surface. 

 

 

Drawing Cross-Sections for a Borrow, Waste or Stockpile Site 

 

This process is similar to “Drawing Cross Sections for As-built to As-designed Comparisons”.  

The main differences are you start your cross section drawing from scratch and you draw two 

surfaces at once instead of one. 

 

1. Create and or open the cross section in the as-built folder.  

 

2. Determine the location of the existing and as-built surface models - *.tin files.  These 

files are typically created by field personnel and are stored in the As-built folder.  If 

you need to create these files, see the section “Creating a DTM”. 
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3. Select “Application>ROAD> 

Cross Sections>Draw Cross 

Sections from Surfaces” from the 

main pull down menu.  The 

“Draw Cross Sections” dialog 

box should open. 

 

4. Select the appropriate Job 

Number and Chain for the Cross 

Sections.    

 

5. There should be two tabs in this 

dialog box; “XS Cells” and 

“Surfaces”.  You should be on 

the “XS Cells” tab.  Near the 

middle of the “Draw Cross 

Sections” dialog box there is a 

“Pattern” panel.   Pattern lines 

indicate where cross sections should be obtained.  Set the pattern toggle to “By 

Station”.  Complete the data for the pattern of the cross sections. The increment sets 

how often a cross section will be cut from a surface.  The Left and Right Offsets must 

be long enough to extend past the earthwork area.   It is better to have these offset 

longer than what is need rather than to short.  A horizontal and vertical scale of 10 is 

common.  This scale will give you about 140’ when printed on traditional sheets.  The 

spacing of the cross sections sets how far apart the cross sections are drawn.  Set this 

spacing so that you have a least 500 feet between elements from different cross 

sections.  If you draw your cross sections are too close, GEOPAK may not be able to 

distinguish which drawing elements belong with which cross section. 

 

6. Next set the tab to “Surfaces”.  

Near the bottom of the dialog 

box there should be a panel for 

surface “Details”.  Select the 

as-built TIN File.  Set the 

“Method” to “Triangles”.  Set 

the “Type” to “Line Strings”.  

The Display Settings for the 

As-built ground should be 

according to the CADD 

Standards for Ground Lines: 

Level = “Grnd Line” 

Color = 1 

Style = 0 

Weight = 2 
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Void lines should be on the same level as as-built ground but the color should be 

white “0”.  After setting these details, select the “Add Surface” button.  This button is 

on the right sided of the dialog box.  The surface information should appear in the 

middle panel. 

 

7. Repeat the previous step for the 

existing ground surface.  Be 

sure to the Display Settings for 

the existing (preconstruction) 

ground according to the CADD 

Standards for Existing Ground 

Lines: 

Level = “Grnd Line Exst” 

Color = 6 

Color = 0 (void lines) 

Style = 2 

Weight = 2 

 

8. Now, you should have to 

surfaces listed in the middle 

panel.  Select the “Draw” button 

in the upper right hand corner of 

the “Draw Cross Sections” 

dialog box.  GEOPAK should draw the as-built surface. 
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Viewing Cross Sections 
03/24/06 

 

You will need to review your cross sections several times as you prepare your earthwork 

calculations.  “Cross Section Navigator” is one of the tools you will use to review your data.  

“Cross Section Navigator” uses a working Cross Section drawing.  A Working Cross Section file 

is a drawing with a series of cross sections with cross section cells. A cross section cell is 

typically green and on level 63.  The cross section cells are location references.  The working 

drawing does not typically have grid lines and the name of the file usually starts off with the 

letters “xs”. 

 

 

 

 

 

 

 

 

 

 

 

You may be able to zoom in and out to 

find the cross section you want to 

review.  However the “Cross Section 

Navigator” tool is much more efficient.  

Select the “Cross Section Navigator” 

tool by selecting 

“Applications>GEOPAK>Cross 

Sections>Navigator” or by selecting 

the icon from the GEOPAK Road tool box. 

 

The Cross Section Navigator dialog box should open.  Use the station pull down field on the left 

of this dialog box to navigate to that station.  
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The following is an overview of some basic navigator tools. 

 

 

Keyin Station  

Key in the desired station and click Enter (on keyboard). The XS Navigator moves to 

the specified station or the closest station if the typed value is not at a section. 

 

Scrolling Tools 

The scrolling buttons enable the user to quickly scan both forwards and backwards 

within the cross section range. The single arrows move forward (>) or backward (<) 

one section each time the button is pressed. The double arrows move to the first 

section (<<) or last section (>>), however, they maintain the same relative positioning 

and window size. The reset navigator (center button on the dialog) returns the user to 

the first section and the entire section is placed on the screen. Therefore, the relative 

window is not maintained. 

 

DP Station Offset 

In this dialog, the Elevation and Offset can be typed in or can be dynamically 

ascertained by clicking Get Cursor XS Position, which expands the dialog. Click the 

button, then place a data point on the cross section. The information is displayed in 

the Elevation and Offset fields. The information can be utilized in any MicroStation 

or GEOPAK command which requires a data point, by clicking the left button when a 

data point is required. 
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Processing Cross Sections for Closure Errors 
03/24/06 

 

At this step you should have a Horizontal Alignment (chain), Existing Ground Cross-Sections 

and Final Ground Cross-Sections.  If you have these items complete you are now ready to check 

to see if your cross-sections can tie within the tolerances that is acceptable to the NDDOT.   This 

step is also need to correct acceptable tie closure errors. 

 

1. Select “Applications>ROAD>Cross Sections>Reports” from the main 

pull down menu.  A “XS Report” dialog box should open with several 

different report buttons.   

 

 

2. From the “XS Report” dialog box, select “User>Preferences”.   The 

dialog box shown below should appear.   Make sure to set the 

tolerance.  Typically it is set at “0.01”. This should be less than what 

will be used for your earth work tolerance (typically “0.05”).   The 

other fields for the Report Header are optional. 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. The “Report Header” dialog box can be closed.  The tolerance setting is not directly 

part of the “Report Header” settings and doesn’t need to be saved.  The optional 

header settings can be saved for other reports by selecting “File>Save”.  The header 

settings can be retrieved by selecting “File>Open”. 

 



 

NDDOT Procedures for Calculating Final Earthwork Quantities 50 
Revised: 11/26/13 

4. Select the “Closure” button from the 

“XS Report” dialog box.  The dialog 

box shown to the right should appear. 

Select the Job number and the chain 

used for the cross sections. 

 

5. Use the “Existing Ground” search 

symbology button (magnifying glass 

looking at cross sections) to set the 

symbology for Existing Ground: 

Level = “Grnd Line Exst” 

Color = 6 

Color = 0 (void lines) 

Style = 2 

Weight = 2 

Set the symbology for the as-built 

ground (Proposed Finish Grade):  

Level = “Grnd Line” 

Color = 1 

Style = 0 

Weight = 2 

 

6. In the Closure part the “Horizontal Tolerance” is 6.00 and “Vertical Tolerance” is 

0.50.  The next step is to set the type of tie constraints that you want.  In the bottom 

portion, set the beginning station and end station of your cross-sections.  Set the next 

button to LT and the button following to Vertical Projection.  There are three small 

buttons on the right side of the dialog box: “Add”, “Modify”, and “Delete”. Click on 

the “Add” button.  Next change the LT bar to RT and click on the Add button.   

 

7. Select the “Output Option” button.  The “Output Option” dialog box should open. 

Check the “Report” box and provide a name for your report.  The file name should be 

Closure.rpt.  Check the “Draw Closure & Trim Elements” box.  Set the “Draw 

Closure Element” to  

Level = “Closure Line” 

Color = 3 

Weight =2 

Style =0 

Set the “Draw Trim Element” to 

Level = “Closure Line” 

Color = 2 

Weight = 2 

Style = 2 
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8. After filling out the “Output Options” dialog box, it can be closed.  Select the 

“Apply” button from the “Closure Report” dialog box.   GEOPAK will compare the 

existing ground to the final ground and determine were they do not tie.  GEOPAK 

will tie the two grounds together with the closure constraints defined.  It is also 

making a closure.rpt file that will indicate which cross-sections have closed within 

acceptable tolerances and which ones need to be corrected. 

 

9. Once GEOPAK has finished processing the cross sections, open the text file 

closure.rpt that GEOPAK just created.    The report file may look similar to the one 

below. 

 

       STATION                LEFT CLOSURE                             RIGHT CLOSURE                     

                          VERT                 HORIZ                VERT                 HORIZ                

0+00.00R1                 0.264                0.000                *1.181               0.000                

0+20.00R1                 * 1.003             0.000                 0.741                0.000                

0+30.00R1                  0.393               0.000                * 1.873              0.000                

 

 

10. The numbers with the asterisk indicate a cross-section that did not tie with the 

tolerance that was specified.  These cross-sections are ones you will need to review 

and adjust.  Once you have tied all the cross-sections within the allowable tolerances 

you are ready to run the earthwork part of GEOPAK. 

 

11. The GEOPAK Closure tool will help tie existing and as-built ground surfaces 

together. However earthwork uses a tolerance to process areas and some sections may 

not directly process.  You may get errors saying some sections don’t tie.   This 

problem might not be a problem with the closure tool.  It could be a problem with 

tolerances. 

 

Some projects will have cross sections that require different tolerances to process.  

You can only use one tolerance while processing the cross sections.  You may need to 

try different tolerances.  Pick the tolerance that processes the most cross sections. 

You may be required to manually correct (edit the drawing) on sections that don’t 

process.  These corrections are usually very small and should have a negligible 

impact on the earthwork calculations.  These corrections are sometimes required 

when you have multiple points that could be tie points. The following drawing 

elaborates on the problem with tolerances. 
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Widening XS Cells (Draw XS Cell) 
10/26/06 

 

Sometimes widening existing XS cells is more productive than redrawing them.  This is often the 

case when the sections have been manually-individually modified (adjusted with MicroStation 

tools vs. GEOPAK and Criteria).  The widening tools can also be used without compromising 

references to “As-designed” drawings (the As-designed and As-built cross sections will 

coincidently over lap). 

 

1. The “Draw XS Cell” tool can be used to widen cross sections.  This tool can be found 

from the main pull down 

“Applications>ROAD>Cross 

Sections>Draw Cross Section 

Cells” or from the Cross 

Sections tools tray as shown. 

 

2. The “Draw XS Cell” dialog box should open.  

Set the upper left option to “Widen”. 

 

3. Set the job number for the XS alignment.  Set 

the Chain for the cross sections. Select the 

beginning and ending stations for the cross 

sections that need to be widened. Set the left 

and right extension length.  Then select Apply.  GEOPAK should widen the specified 

sections.  
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Draw Pattern Lines from XS 
12/31/08 

 

Sometimes a plan view drawing of where the cross sections are located needs to be created or 

recreated.  This typically occurs when pavement and base layers need to be drawn into the cross 

sections and the sections are not at even intervals and or widths.  See “Drawing Pavement and 

Base Into Cross Sections” for when this is needed. 

 

1. Create and or open your shape drawing (shape.dgn).   

 

2. Select “Applications>ROAD>Cross 

Sections>Draw Patterns from Cross 

Sections” from the main pull down menu.  

The following dialog box should appear. 

 

 

 

3. Set your “XS DGN File”, “XS Baseline”, and 

Symbology.  The symbology is set as shown.   

 

4. After your settings have been selected, select the 

“Draw Pattern Lines” button.  GEOPAK should draw 

pattern lines into your drawing that follow your 

alignment and match the widths and intervals of your 

cross sections. 
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Drawing Pavement, Base and Topsoil into Cross Sections 
11/17/13 

 

Pavement and bases need to be drawn into most roadway cross sections in order to calculate the 

correct earthwork quantities.  Both existing-preconstruction and as-built layers (pavement, base 

and sometimes topsoil) may have to be drawn into the cross sections.  These materials need to be 

drawn so that they can be excluded from the excavation and fill calculations for soil suitable-

grading. 

 

Sometimes materials can be accounted for outside of the GEOPAK Calculations and they don’t 

need to be drawn.  Here are some examples: 

 

1. If existing topsoil = as-designed topsoil (plan quantity) = as-built topsoil, then it is 

often assumed that actual “common excavation” = GEOPAK calculated “common 

excavation” – plan quantity topsoil. 

 

2. If existing pavement and or base removed is all in a fill area (as-built suitable grading 

material is above), then the entire pavement or base removal quantity can be added to 

the GEOPAK calculations for the actual common excavation quantity.  See example 

case 1. 

 

3. Similarly if all the existing pavement and or base removed is completely in a cut area 

(as-built surface is below removed pavement and base), then the entire pavement or 

base removal quantity can be subtracted from the GEOPAK calculations for the 

actual common excavation quantity.   See example case 2. 

 

4. If as-built pavement and or base added is all in a fill area (existing fill-soil-suitable 

grading material is below the added materials), then the entire pavement or base 

added quantity can be subtracted from the GEOPAK calculations for the actual 

embankment.  See example case 1. 

 

5. Similarly if all the as-built pavement and or base added is completely in a cut area 

and below existing pavement and base to be removed, then the entire pavement or 

base removal quantity can be added to the GEOPAK calculations for the actual 

embankment.  See example case 2. 

 

Sometimes materials can’t be accounted for outside of the GEOPAK Calculations and need to be 

drawn.  Here are some examples: 

 

6. If the existing pavement and or base are in both fill and cut areas or removed and 

added surfaces overlap, then the layers need to be drawn in order to determine correct 

quantities. See example case 3.   
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7. If the as-built pavement and or base are in both fill and cut areas or remove and added 

surfaces overlap, then the layers need to be drawn in order to determine correct 

quantities.  See example case 3. 

 

8. The existing materials removed and the as-built materials added also need to be 

drawn in the cross sections if a correct mass diagram and or average haul calculations 

are required. 

 

The examples shown on the following page demonstrate the above concepts.  In these examples 

the original GEOPAK calculations did not account for the existing and as-built materials 

(pavement and base that was added or removed).  All of the situations have the same common 

excavation quantity calculated by GEOPAK, same proposed pavement volume and same existing 

pavement volume.  However these volumes need to be interpreted differently.  All three cases 

have a different actual common excavation quantity.
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If you need to draw materials into your cross sections, GEOPAK Criteria can be used to expedite 

the process.  GEOPAK Criteria is a set of instructions that tell MicroStation how to draw. 

Drawing Cross Section Layers without Project Manager 

 

1. Copy all the files in the directory S:\STANDARD\V8i\GEOPAK\Criteria\As-

built_Earthwork to your working directory.  Do not copy the directory folder itself. 

The files need to be placed directly into your working directory.  Note, you might not 

need all the files. 

 

2. Edit the input file exst_material.inp with the GEOPAK “Text Editor” or Notepad.   

The lines that you need to edit in your input file are: 

 

“xs dgn =” Set to the directory and dgn file that has your cross-sections 

 

“Pattern by Station” or “Pattern dgn” 

 Set all the pattern setting used to create the cross sections.  ; job 

number, baseline, horiz scale, vert scale.  “Pattern by Station” will 

use the additional variables; begin station, end station, even, lt, and 

rt.  “Pattern dgn” will use the additional variables; type, lvname, 

and co (color).  Either “Pattern by Station” or “Pattern dgn” 

settings will be used but not both settings.  These settings need to 

match the settings used to create the surfaces.  These setting will 

be different if “Pattern dgn” is used.  The following are examples. 

 

Pattern by station 

    pattern set 

        job number = 001 

        baseline = EXHWY12 

        horiz scale = 10 

        vert scale = 10 

        beg station = 1808+00 

        end station = 1908+00 

        even =  200.00 

        lt =  300.00 

        rt =  300.00 
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Pattern dgn = c:\CADD\belinda\shape.dgn 

    pattern set 

        job number = 001 

        baseline = EXHWY12 

        horiz scale = 10 

        vert scale = 10 

        type = line, line_string 

        lvname = Pattern lines 1 

        co = 1 

 

“shape cluster baseline” Set to the horizontal alignment used for cross sections 

“shape cluster profile” Set to the vertical alignment used for cross sections 

“shape cluster pgl chain” Set to the horizontal alignment used for cross sections 

 

“Write XS Into Dgn”  Set to the directory and dgn file that has your cross-sections 

 

3. Once you have made these changes, save the file.   

 

4. Edit the criteria file “variables_Preconstruction.x”.  This file has re-definable 

variables near the end of the file that control the width and thickness of the layers 

drawn.  The standards manual has picture of what criteria will draw (Appendix J-

Material_Layers_From_Surface).  The standards manual also lists what these 

variables represent (Appendix J-Variables).  Only the materials removed or mined 

and blend need to be drawn.  If existing base is dealt with as common excavation, it 

doesn’t need to be drawn.  If you don’t want to draw a layer, set the “depth” to 0.  

The following is a list of variables that should be redefined. 

 

_d_draw_asbuilt - Set to 1 to draw asbuilt surfaces.  Set to 0 to draw 

existing – preconstruction surfaces. 

_d_exst_aggr_depth1 - depth of exst aggr at center of road 

_d_exst_aggr_depth2 - depth of exst aggr at outside edge of mine and bend 

shoulder 

_d_exst_aggr_slough_width  - horizontal width from top to bottom of slough 

_d_exst_aggr_width - width of exst aggr (mine and blend) from centerline 

_d_exst_asph_depth1 - depth of exst asph at center of road 

_d_exst_asph_depth2 - depth of exst asph at outside edge of mine and bend 

shoulder 

_d_exst_asph_slough_width- horizontal width for top to bottom of slough 

_d_exst_asph_width - width of exst asph (mine and blend) from centerline 

_d_exst_conc_depth1 - depth of exst conc at center of road 

_d_exst_conc_depth2 - depth of exst conc at outside edge of shoulder 

_d_exst_conc_width - width of exst asph from centerline 

_d_exst_ts_depth - depth of exst topsoil 

_d_exst_ts_start - distance from centerline to useable exst topsoil 

_d_exst_ts_transition_width  - horizontal width from 0 to full depth 
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5. Excavation limits indicate where topsoil is stripped and where earthwork is 

calculated.    The as-built survey should indicate where the tie point is located with a 

break line.  This information should be in the drawing DTM_*.dgn and on level name 

“Tie Point Line Exst”.  If this line is found the criteria will draw the excavation limits 

at the tie point.  If it is not found, the criteria sets the excavation limits at a fixed 

distance or 1’ outside the as-built ground as determined by the variable 

“_d_exc_Lim_d1”.   A line in the criteria “standard.x” may need to be modified. 

 
   “define_dgn "Exc_Lim_From_Dgn"   dgn=DTM.dgn    lvName=Tie Point Line Exst   co=6” 

 

The file “DTM.dgn” may need to be edited with the exact name of the drawing with 

the “Tie Point Line Exst” break line. 

 

 

6. Open the as-built cross sections and select 

“Applications>Road>Cross Sections>Process 

Cross Sections”.  The box to the right should 

appear.  Fill out the box as shown.  Once you 

have the box filled out you want to choose the 

Apply box.  

 

7. GEOPAK will draw the material layers into 

the cross sections.  GEOPAK will also create 

a text file exst_material.log.  If problems drawing the layers are encountered, 

reviewing the log file may help you find the problem. 

 

8. Steps 2-6 will have to be repeated for the as-built material layers.   However this time 

use the input file “final_material.inp” and write the log file final_material.log.  Use 

the file “variables_asbuilt.x” to define the cross section variables. 
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Drawing Cross Section Layers using Project Manager 
11/20/08 

 

1. Select the Project Manger file, and user for your project.  If the general settings for 

project manager have not been set up, see the section named “Project Manager for 

GEOPAK Road”. 

 

2. Select the “Proposed Cross 

Sections” button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. A “Select Run” dialog box should appear.  Within this dialog 

box, select “Run>New”.  

 

 

 

 

 

 

 

4. Provide a name for the run.  The naming convention for the 

run is not very important.  It only has to be memorable. The 

description is optional. Select the OK button on the New Run 

Name dialog box.  The name of the newly created run should 

appear in the “Select Run” dialog box. Double click on the 

name of the newly created run. 
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5. The proposed Cross Sections dialog box 

should appear.  On the left side of this 

dialog box is a panel with categories of 

settings that need to be completed. Click 

on the first category “XS DGN File”. Use 

the icon that looks like a magnifying glass 

to select the working cross section 

drawing.  Change the “Tolerance” for 

drawing elements to 0.01. 

 

6. Select the “Pattern” category.  Several of 

the categories have an option called “Use 

Working Alignment Definition”.  This 

manual will not use this option.  The 

NDDOT usually uses pattern lines that are 

drawn “By DGN File”.  This option is a 

toggle button option.  Complete the 

information for the pattern lines.  You may 

have to open your pattern line drawing 

(see section “Drawing Pattern Lines from 

XS).  The Horizontal Scale and Vertical 

Scale should both be 10.  The “Search 

Criteria” tells GEOPAK how to look for 

the pattern lines.  Usually “Lv Names” and “Colors” is enough information segregate 

different sets of pattern lines. 

 

7. Select the “Existing Ground” category.  

Provide the drawing name and Search 

Criteria for the lines and line strings that 

make up the existing ground in the working 

cross section drawing.  Don’t forget to 

include the ground void line symbology if 

used.  Ground void lines are often used 

through areas that disrupt a DTM such as a 

body of water or building.  These lines are 

needed to keep the existing ground model 

continuous.  Parts of GEOAPAK (criteria) 

may not work correctly if the ground is not continuous.  

 

8. Select the “Shapes” category.  This 

category refers to supper elevation shapes.  

As-built cross sections seldom reference 

back to supper elevation shapes. Change the 

button toggle to “Shapeless”.  
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9. Select the “Shape Cluster” category.  This category will be used even if shapes are not 

used.  This category is used to tell GEOPAK what to draw. Special separate files or 

subroutines named “Criteria” files contain drawing instructions for GEOPAK.  Use this 

dialog to tell GEOPAK how to apply the criteria – instructions to your proposed cross 

sections.  This manual will used an addition tool to help simply this process. 

 

10. First select the chain, profile and tie that apply 

to your as-built cross sections.  The “Tie” 

value is usually 0.  The tie value is use to 

apply the chain alignment at an offset.  After 

these fields have been filled out, select the 

“Add” button near the middle of the dialog 

box.   

 

 

 

 

 

 

 

 

 

 

11. The field information will be added as an 

entry in the top panel. Select this entry and 

the “Typical” button will be enabled.  

Select this button to launch the 

supplemental typical section generator tool. 

 

 

 

 

 

 

12. As the “Typical Sections” generator tool 

opens, you will receive an Alert about 

running in “SHAPELESS” mode.  Select 

“OK” to continue.  We will be selecting a 

typical that doesn’t use shapes.  This typical 

will be applied to the cross sections.  
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13. In the lower left area of 

the “Typical Sections” 

dialog box, there is a 

panel that can be used 

to select different types 

of typicals.  Select the 

“Cell” (typical) named 

“MLFSA” (Material 

Layers from Surface 

Advanced).  

 

14. This one typical can be 

modified to address 

many different types of 

as-built surfaces.  The 

criteria (subroutines) 

can account for many 

different project variations.  Different typicals can also be applied to the same roadway a 

different stations.  This manual will not elaborate on this situation.  In the lower right are 

of the dialog box is a “Range” panel with toggle button for applying the typical to the 

whole chain.  Use the “Apply to Whole Chain” default and select the “Apply” button at 

the bottom of the dialog box. 

 

15. The “Typical Sections” dialog box 

will have closed and several changes 

to the “Proposed Cross Sections > 

Shape Clusters” will have been 

made such as adding “side slope 

conditions” and “Criteria” files.  An 

extra category named “Redefinable 

Variables” will also have been 

added.  If you examine the contents 

of your working directory, should 

also note that 3 criteria files have 

been added; standard_symbology.x, 

material_layers_from_surface_ 

advanded.x, and exposed_ 

redefinable_variable_english.x 
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16. In the “Proposed Cross Sections” dialog box, select the “Define DGN Variables” 

category.  Toward the middle of the dialog box is a variable selector tool.  Select this tool 

and a list of drawing features will appear. You need to tell Geopak how to find these 

elements because it will use the information to draw the cross section in the right 

location.   This information needs to be defined even if you don’t plan on using it 

(example, “concrete edge” needs to be defined even though there is no concrete on the 

project.  “concrete edge” also needs to be defined if the location is described by 

redefinable variables). 

 

 

 

17. Double click on the variable name 

then define where this feature can be 

found in project drawing.  After you 

have defined one feature make sure 

to use the “Add” button.  Each 

variable needs to be defined and 

added one at a time.  When the 

variables have been defined, they 

should appear in the top panel.  

 

18. The next category is “Define 

Variables”.  This category is seldom 

edited because most of the regular 

(fixed) variables have been defined 

in the CADD Standards 

(standard_symbology.x). 
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19. Select the “Redefinable Variables” category.  There will be a list of redefinable variables 

in the top right panel.  Each variable will have a default value.  These values can be 

changed by double clicking on the variable name.  Project manager will remember these 

values without change the criteria files.  You do not need to change the variable values 

in the criteria files with exposed redefinable variables. Explanation of what the 

variables define is built into the criteria files and discussed in the CADD Standards. 

 

20. Select the “Plot Parameters” category.  

The default values are fine for this as-

built example.  

 

21. The “Drainage” Category is seldom used 

at the NDDOT. 

 

22. After information for the “Proposed 

Cross Section” dialog box and its many 

categories has been completed.  Select 

“File>Save Setting” from this dialog box.  

This step is extremely important 

because if you don’t do it you could 

lose your work. 

 

23. After the settings have been saved, select 

“File>Run” from the “Proposed Cross Sections” 

dialog box.  Another dialog box will open with 

several processing options.  Switch the Output toggle 

from “To Screen” to “To Log File”.  The name 

temp.log is fine.  This is a name for a text file that 

GEOPAK will create.  It is often is used in trouble 

shooting problems. Select the “Apply” button to have 

GEOPAK draw the cross section features. 
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Earthwork from Cross Sections 
11/17/13 

 

To run earthwork in GEOPAK you need to create an earthwork input file.  This input file is a set 

of instructions for GEOPAK to calculate earthwork quantities.  GEOPAK Project Manager can 

be used to create this file or the file can be edited with a text editor. 

 

Editing and Running Earthwork without Project Manager 

 

1. Copy the file S:\STANDARD\ V8i\GEOPAK\Criteria\As-built_Earthwork \Earth.inp 

and paste into your working directory. You may have already have done this if you 

drew pavement materials into your cross sections (Drawing Pavement and Base into 

Cross Sections). 

  

2. Edit the file with the GEOPAK “Text Editor” or Notepad.   The lines that you need to 

edit in your earth.inp file are: 

 

“xs dgn =” Set to the directory and dgn file that has your cross-sections 

 

“fill mult factor =” Set to the fill factor for suitable grading materials.  

Example, fill material with 25% compaction and or loss should 

have a “fill mult factor” of 1.25.  Materials not used for common 

excavation should remain at a factor of 1.00. 

 

“Proposed Undercut” These paragraphs are used to account for materials that are 

brought on to the project so that GEOPAK can correctly calculate 

common excavation and fill.  If you are working with a simple 

borrow, waste or stockpile site, these paragraphs can be deleted.  

 

If the proposed material is base including material from mining 

and blending, then the “soil type” should match the “Existing 

Suitable Material” for blended material.  Do not use the same “soil 

type” for existing materials and proposed materials unless the 

material is going to be reused. 

 

“Existing Suitable Material” These paragraphs are used to account for materials 

that might stay in place. Base material on a project may be able to 

remain in place for a mine and blend project.  These paragraphs 

can be deleted if you are calculating earthwork for a simple 

borrow, waste or stockpile site.  Note “Existing Suitable Material” 

will still be removed if the proposed material “soil type” doesn’t 

match.  Do not process existing base if it is to be addressed as 

common excavation. 
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“Existing Unsuitable Material” These paragraphs are used to account for materials 

that must be moved or removed.  This material should not be 

accounted for in the mass ordinate.  Example if existing topsoil and 

as-built topsoil overlap in certain areas, the term “Unsuitable” 

would make GEOPAK excavate the material even though it would 

be replaced again.  The term “Suitable” would allow for the same 

topsoil to remain in place. 

 

 “Skip Areas” Revise these lines for areas where earthwork should not be 

calculated such as over bridges.  Additional lines will need to be 

added if additional skip areas are required.  This paragraph can be 

deleted if there are no skip areas. 

 

“Volume Adjustment” Revise these line for borrow and waste sites.  “Volume 

Adjustments” are also used for approach, interchanges and 

intersections.  Add or Delete these paragraphs as needed. 

 

“Process Earthwork for Baseline =” Set the chain name and job number for your 

cross sections. 

 

“beg sta” Beginning station of your chain 

 

 “end sta”  End station of your chain 

  

3. Sometimes corrections for excavation and embankment need to be accounted for 

outside of the cross sections.  Examples of these corrections include borrow and 

waste sites.  They also include earthwork from adjoining or intersecting roadways.  

Variations of the following paragraph may need to be added.  Multiple corrections 

can be made at different locations by adding multiple paragraphs.  These paragraphs 

should be included in the input file right before the “Write Earthwork Shapes” 

statement. 

    

 volume adjustment /* Borrow from Wetland */ 

 station = 98+00 

 soil type = suitable_grading 

 common excavation volume = 125354  

  

4. Once you have made these changes you can save the file.   
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5. Now go back to MicroStation and choose 

“Applications>Road>Cross Sections> 

Process Cross Sections”.  The box to the 

right should appear.  Fill out the box as 

shown.  You may want to adjust the 

earth.log file name if you will have 

multiple earth work runs (different cross 

sections drawings).  Once you have the 

box filled out you want to choose the 

Apply box.  

 

6. GEOPAK will now run 

through each cross section 

and calculate the fill and 

cut.  If GEOPAK can not 

tie the two grounds 

together you will get an 

“Earthwork Error 

Message”.  You can 

interactively correct some 

cross sections as GEOPAK 

calculates earthwork.  If the “DP” button is enabled, it can be used to help find the to 

the problem area. “DP” stands for Data Point.  A MicroStation tool such as “Place 

Line” or “Zoom In” can be used in conjunction with the GEOPAK “DP” button to 

find this problem area.  Example if the above error message appears, you could select 

the MicroStation “Place Line” tool then select the “DP” button from the “Earthwork 

Error Message” dialog box.  MicroStation will start to draw a line from the 

coordinates of the problem area.  The place line command could then be canceled and 

then you could correct that specific cross section.   After the cross section has been 

corrected the “Redo” button can be selected and GEOPAK will try to reprocess the 

cross section.  If you choose to “Skip” a cross section, earthwork for that section will 

not be calculated, at some time you will need to tie the two grounds together.  This 

process is just a trial and error situation.  The log file that is produced will have all of 

your calculation and can be printed out. 
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Running Earthwork with Project Manager 
11/20/08 

 

1. Select the Project Manger file, and user for your project.  If the general settings for 

project manager have not been set up, see the section named “Project Manager for 

GEOPAK Road”. 

 

2. Select the 

“Earthwork” button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. A “Select Run” dialog box should appear.  Within this 

dialog box, select “Run>New”.  

 

4. Provide a name for the run.  The naming convention for 

the run is not very important.  It only has to be 

memorable. The description is optional. Select the OK 

button on the New Run Name dialog box.  The name of 

the newly created run should appear in the “Select Run” 

dialog box. Double click on the name of the newly 

created run. 

 

5. The Earthwork dialog box will open.  On the 

left side of this dialog box is a panel with 

categories of settings that need to be 

completed. Click on the first category “XS 

DGN File”.  Use the icon that looks like a 

magnifying glass to select the working cross 

section drawing.  The “Baseline”, “Begin 

Station” and “End Station” fields should 

automatically fill in when the working XS drawing is selected.  
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6. Select the “Soil Types” category.  

This dialog is used to tell GEOPAK 

how drawing elements represent 

different soil types.  There are 6 

different classes of earthwork 

elements; Existing Ground, Existing 

Suitable, Existing Unsuitable, 

Proposed Finished Grade, Proposed 

Undercut and Excavation limits.  

 

Existing Ground must always be 

defined. The “Soil Type” name 

should be the same name used in for 

the Proposed Finished Grade.  Soil 

types with the exact name are the  

same materials even if it comes from 

a different earthwork class (example, the soil type named “suitable_soil” that is 

excavated from the “Existing Ground” classification can be used as fill for soil named 

“suitable_soil” in the “Proposed Finished” classification. 

 

“Proposed Finished Grade” must always be defined.  This is the As-built surface 

including closure lines.  Don’t forget to adjust the “Multiplication Factors” for “Fill” 

(example, project that have 20% additional soil for shrinkage, should be entered as 1.2). 

 

“Existing Unsuitable” class is often used for topsoil stripping.  If the “Existing 

Unsuitable” classification is not used for topsoil stripping,  GEOAPK will assume it 

acceptable to build – embank directly on top of the topsoil.  “Excavation Limits” must be 

used in conjunction with “Existing Unsuitable” features.  Existing Unsuitable is also used 

for pavement and base removals. 

 

“Existing Suitable” class is used for full depth reclamation projects.  The existing 

pavement and base can remain in place. 

 

Proposed undercuts are for proposed (as-built) materials such as topsoil, base and 

pavement. 

 

7. Select the “Earthwork Shapes” category.  

Turn on the options for “Draw Earthwork 

Shapes” and “Stratify Shape Color”.  Set 

the symbology for the earthwork shapes.  

The level should be changed to “Earthwork 

Shapes 1”.  
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8. Select the category “Output Format”.  

Turn on the options as shown.  In the 

lower right area of the dialog box are 

arrows (< and >).  Click and re-click on 

the “>” arrow until the display format 

shows only, Excavation and Fill.  

 

 

 

 

 

9. The “Add/Subtract Volume” category is 

used to make earthwork corrections 

within the earth log (earthwork report).  

Corrections within the earth log are 

important for creating a Mass Diagram.  

Typical corrections include borrow sites 

and extra material needed for 

intersections and approaches. Materials 

for centerline pipe may also need to be 

accounted. These corrections should be 

thought of in terms of the roadway project; material from a borrow pit is additional 

excavation, material needed for approaches is fill.  

 

10.  The category “Centroid Adjustment” is seldom used by the NDDOT because most of our 

control alignments are close to or within the actual earthwork, and the stationing 

measurements are close enough.  The “Centroid Ajustment” is important when the actual 

distance between stations is different than the distance calculated from stationing alone 

(example, the distance between station 1+00 and 2+00 is 100 feet if measured at 

centerline, but it would be longer if it was measured on the outside of a curved 

alignment). 

 

11. The category “Skip Areas” is used to omit areas of earthwork. The category “Ignore 

Areas” calculates volume through the station range but none of the data within that 

station range is used in the end area calculations. Skip Areas are often used for bridges. 

Ignore Areas are sometimes used for unique cross sections that don’t represent earthwork 

correctly. 

 

12. The category “Sheet Quantity” is seldom used by the NDDOT.  This category can be 

used to create a special custom ASCII report.  This report is different than the earth log 

file. It can be imported into Excel and or used to print individual cut and fill quantities on 

the cross section sheets. 
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Reviewing Earthwork Calculations 
 11/20/08 

 

After running earthwork (Earthwork form Cross Sections) you should have a report (earth.log) 

and GEOPAK should have drawn earthwork shapes into your cross section drawing.  These 

earthwork shapes should be on level “Earthwork Shapes 1”.  GEOPAK assigns (in ascending 

numerical order) each material type two colors, one for cut and one for fill.  Even color numbers 

are assigned to excavation and odd numbers are assigned to fill.  Below is an example of color 

assignments based on a specific earthwork setup (run-input file).  Your color numbers may vary 

based on your setup. 

 

Soil Type  Process Color 

suitable_grading cut  0 

suitable_grading fill  1 

base   cut  2  (will only occur if salvaging base) 

base   fill  3 

asphalt   cut  4  (doesn’t  occur, requires processing after salvaging) 

asphalt   fill  5 

base_removed  cut  6 

base_removed  fill  7  (doesn’t  occur, would use the term ”base” instead) 

asphalt_removed cut  8 

asphalt_removed fill  9  (doesn’t  occur, requires processing after salvaging) 

 

 

If you reprocess earthwork, these shapes should be deleted before reprocessing.   

 

These earthwork shapes should be reviewed in order to confirm that earthwork was correctly 

processed.  Typically a small percentage of the cross sections are examined with MicroStation 

measurement commands.  Every single shape in the selected cross section is measured with the 

MicroStation “Measure Area” tool or the supplemental “Measure Area” tools.  These areas are 

then added according how the earthwork was intended to be process.  These calculations are then 

compared to the GEOPAK calculations as compared in the earth.log. 
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Application Attribute Viewer 
11/20/08 

 

The Application Attribute Viewer is GEOPAK tool that can be used to help review earthwork 

shapes.  GEOPAK attaches additional information to drawing elements such as earthwork 

shapes. This information is attached as Adhoc Attributes. 

 

1. Select “Applications>Road>Element 

Attributes” from the main pull down 

menu.  The Application Attribute Viewer 

dialog box should open.  

 

2. Select the “identify CIVIL Element” 

button.  Then click on an earthwork 

shape.  Information about the shape such 

as end area will appear.  
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Creating Cross Section Layout Sheets 
11/17/13 

 

1. Create a new drawing for the cross section layout sheets.  The NDDOT Standard seed 

file should be used (NDDOT_seed.dgn).  The layout drawing should be named 

according to the CADD standards (200XS*.dgn). GEOPAK will reference in the 

working cross section drawing (xsec*.dgn) latter in this process. 

 

2. Within the 200XS*.dgn, set the “Drawing Scale” (Settings >Drawing Scale) to “Full 

Size 1=1” and save settings.  This is done because GEOPAK can’t correctly place 

cells with tags at different drawing scales. 

 

3. Copy the file S:\STANDARD\V8i\GEOPAK\Sheets\NDDOT.xssl and pasted into 

your working directory.  

 

4. Open your working cross section drawing (xsec*.dgn).  

 

5. Open the “Cross Section 

Sheet Composition” dialog 

box.  It can be found in the 

pull down menu 

“Applications>ROAD>Cross 

Sections>Cross Section 

Sheet Composition”, project 

manager or the standard tool tray as shown. 

 

6. From the cross section sheet composition dialog box, attach the standard library by 

selecting “File>Sheet Library>Attach” and pick the file “NDDOT.xssl” that you 

copied into your working directory.   

 

7. Most of the cross section sheet settings should be set up for the typical project.  

However if you plan on changing several of the default settings, you will probably 

want to save these revised setting.  The following are some examples why you may 

want edit the default settings. 

a. Different level search criteria 

b. Different “Baseline X Offset”   

c. Different cross section spacing 

d. Different earthwork table setup 

 

Most of the settings have been set up for the typical project.  The settings that don’t 

typically need to be edited are not reviewed here.  The follow is a review of the 

setting that you will have to setup within the “Cross Section Sheet Composition” 

dialog box. 
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8. First, select your “Active Cross Section Sheet”.  The most common “Active Cross 

Section Sheet” setting is  “XS A 20 Scale or Less”.  The “Active Cross Section 

Sheet” setting contains groups of related standard default settings. 

 

9. Within the “Cross 

Section Sheet 

Composition” dialog box 

you can pick the group of 

settings that you want to 

review or edit from the 

left panel.  Select the 

group of settings for “XS 

DGN File” and adjust the 

settings for your working 

cross sections drawing 

(xsec*.dgn).   

 

 

 

10. From the group of settings dealing with “Sheet DGN File”, set the “Sheet DGN” to 

your cross section layout drawing (200XS*.dgn).  Note the layout file needs to exist 

before laying out the sheets.  Also note, the bottom two options; “Detach Existing 

Sheets Before Processing” and “Attachment: All Sheets in Active Model”.  Use the 

Attachment “All Sheets in Active Model” option.  

 

11. From the “Sheet Dimensions/ 

Cell” group of settings, set 

the cell to the final plot scale 

for the sheets (usually 20 or 

10 scale).  

 

 

 

 

 

 

 

 

 

 

12. This guide doesn’t explain the “Label Earthwork Quantities” options. This is an 

optional labeling tool that needed to be setup before processing earthwork.  From the 

group of settings dealing with “Earthwork Quantity Labels”, turn off the “Label 

Earthwork Quantities” options.  
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13. Layout the cross section sheets by selecting “Layout Sheets”.  At this point Geopak 

will reference, arrange and clip the xsec*.dgn drawing. 

 

14. The Drawing Scale can now be corrected.  This will fix the sheet border scale.  Set 

the “Drawing Scale” to what was used in step 11.  

 

15. Review the drawing (200XS*.dgn).  Future changes to reference cross sections will 

automatically show up in the sheet layout drawing.   Edit the tags for the sheet cells as 

necessary. 
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